Home Asset Management

Export Selected Items task does not work on Software Assets

Tony_CollettTony_Collett Cireson Support Super IT Monkey ✭✭✭✭✭
When I select some or all of our Software Assets, I can click on the "Export Selected Items" task, but when opening the CSV file that is created, it only displays one item (or sometimes none). I have also tried to Select all (Ctrl+A) and Paste (Ctrl+V) into a Spreadsheet, but it still only grabs the first item.

With other views, you can select all and past the items into a spreadsheet, but you have to wait a certain amount of time until the Task bar says "Selected Items (XXXX)" for that to work. Software Assets never shows that bar and only shows a single asset, or tasks for the view. I've waited for hours after selecting a bunch of items and I still can't get all the information, only copying one asset. 

Is there a Powershell script or something I can use to get all these Software Assets? 

I am using the latest version of Cireson Asset Management as well. 


  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Hi Tony,

    How many SWAs have you got? I've got 39 in my lab and when i select all, I get 'Selected Items (39)' straight away. Can you try with just 2 items to see if the multiple select mechanism is working or if its just so slow that it can't do it even after hours.
    I'm not running the latest version in my lab so I will upgrade and retest for you ASAP.
    Also, in the meantime, PowerShell: Yes, always.

    $SWA = Get-SCSMClass Cireson.AssetManagement.SoftwareAsset$
    Get-SCSMObject -Class $SWA | Select-Object * | Export-Csv -Path C:\Users\geoffross\Downloads\SWA.csv

    You can replace the * with a list of properties if you only want to output certain columns.
    Also, please note, this needs the SMLets module installed and loaded.

  • Tony_CollettTony_Collett Cireson Support Super IT Monkey ✭✭✭✭✭
    We have 434 SWAs in our system. Multiple selection didn't work at all for any number of selections. 

    However in my testing I found that it's based on the view - we have a custom view which isn't selecting any objects, but the OOB default Cireson SWA view worked perfectly fine. Time to investigate why our view is broken. 
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Ahh, very interesting. Let me know how you get on. But try the PowerShell, it's quicker anyway. Or Asset Excel could help you out.
Sign In or Register to comment.