Home Analyst Portal

Query Results empty for one user

Christopher_CarverChristopher_Carver Customer Adept IT Monkey ✭✭
I have one user that cannot see any of the query results for one specific adv. RO. This is the only RO that uses query results. The account can access and see all the appropriate ROs for that account. Other accounts have no problem viewing the query results.

I have performed the following steps to try to identify and correct this issue:
  1. Checked RO permissions. Though he can see and get into the RO and see all of the prompts and pull downs, I still checked his access rights with the stored procedure spCheck_UserRequestOfferingPermissions. The account does have access to the SO and RO.
  2. I have rebuilt the CacheBuilder by truncating the [ServiceManagement].[dbo].[LastModified] table, restarting the CacheBuilder service account, and then waiting until all 6 rows reappear.
  3. I had the account refresh their browser cache on both IE and in Chrome.
Portal Information:
Current Portal Version: 8.3.1.2012
Management Pack Version: 7.7.2012.185

Answers

  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    Does the user have rights to see the objects in the results. basically with Ciresons portal all users need edit rights to CI's in any query result or template.
  • Christopher_CarverChristopher_Carver Customer Adept IT Monkey ✭✭
    That might be it as I do not recall setting up rights on the CIs. How would I go about checking that in SCSM or Cireson?
  • Christopher_CarverChristopher_Carver Customer Adept IT Monkey ✭✭
    Would having the table [ServiceManagement].[dbo].[Access_CI$User_ConfigurationItem] being blank be the reason? But then why can others see the options? Still a mystery. 

  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    All the security rights are controlled via the SCSM console user roles. Check what role the said user is a member of and then check if they have task rights to edit CIs
    HTH
  • Christopher_CarverChristopher_Carver Customer Adept IT Monkey ✭✭
    It was pretty clean, the account is in an a 2K member AD group which has been assigned the role. If the other 2K accounts had an issue, I would have been getting some nasty emails. Dropping accounts in the AD group setup in the role has been standard for the last 2-3 years while using Cireson.

    Anyways, I gave myself the weekend off trying to figure this out and now the account holder says they see all of the query results. While I am glad, it irks me to not know why. If it happens once, it's likely to happen again.

    I might look into creating a query that checks account right access to CI. That would then atleast give me a starting point to build from.   
  • Jeff_LangJeff_Lang Customer Advanced IT Monkey ✭✭✭
    I've seen similar issues with other things, and the access was usually right after a couple of days. Since we have setup a scheduled task to restart the CacheBuilder every day, after the AD Connector Sync's, we are no longer seeing extended delays in access etc. not sure if that will assist in this instance or not though.
Sign In or Register to comment.