Home Analyst Portal

Adding a multipleObjectPicker scoped to Domain User or Group isn't working properly

Aaron_BoockAaron_Boock Customer Advanced IT Monkey ✭✭✭
Hello,

I'm trying to add a multipleObjectPicker to ChangeRequest.js.  I have multipleObjectPickers already for Organization, Location, and Hardware Asset classes - each scoped accordingly and fully functional.

My new Domain User or Group multipleObjectPicker scopes to the class for adding, but after clicking Add and Save, the item isn't listed/displayed on the form.  If I set Scoped = false, I'm able to see the item (along with all other related items).

Has anyone else successfully add a similar multipleObjectPicker?  Here is my code snippet if anyone else wants to try and let me know if it works in their environment.

{
name: "Implementers",
type: "multipleObjectPicker",
PropertyName: "RelatesToConfigItem",
ClassId: "eca3c52a-f273-5cdc-f165-3eb95a2b26cf",
PropertyToDisplay: {DisplayName: "Display Name"},
Scoped: true
}

Best Answer

  • Aaron_BoockAaron_Boock Customer Advanced IT Monkey ✭✭✭
    Accepted Answer
    I switched to a different classId.  I assume Domain User or Group is a more complicated class.

    {
    name: "Implementers",
    type: "multipleObjectPicker",
    PropertyName: "RelatesToConfigItem",
    ClassId: "10a7f898-e672-ccf3-8881-360bfb6a8f9a",
    PropertyToDisplay: {DisplayName: "Display Name", Department: "Department", UserName: "Network ID"},
    Scoped: true
    }

Answers

  • Aaron_BoockAaron_Boock Customer Advanced IT Monkey ✭✭✭
    Accepted Answer
    I switched to a different classId.  I assume Domain User or Group is a more complicated class.

    {
    name: "Implementers",
    type: "multipleObjectPicker",
    PropertyName: "RelatesToConfigItem",
    ClassId: "10a7f898-e672-ccf3-8881-360bfb6a8f9a",
    PropertyToDisplay: {DisplayName: "Display Name", Department: "Department", UserName: "Network ID"},
    Scoped: true
    }
  • AJ_WittenbrinkAJ_Wittenbrink Customer IT Monkey ✭
    I am curious does this render properly on a mobile view?  I tried to set Properties to Display and scope, and it will not load.  Will work fine on a desktop browser.
Sign In or Register to comment.