How can I prevent an email chain ending up in an end users comment when they reply via email

Richard_ChalkerRichard_Chalker Customer IT Monkey ✭
Hi All,

Having not used SCSM for around 5 years and only just getting back into it, I'm a bit stuck with how I prevent a huge long email chain appearing in the end user SCSM comment when they reply via email to an analyst comment. 

Is there a method to make it so only the end user comment is added into SCSM without the email chain which includes an analyst comment? 

Thanks,

Richard

Best Answer

  • Richard_ChalkerRichard_Chalker Customer IT Monkey ✭
    Accepted Answer
    Hi all,

    I managed to look into this a bit more today (been a bit busy leading up to Christmas) and found the option that was causing my problem. 

    My colleague who created the exchange connector had checked the box that says "Append the full body of the email message (up to 4,000 characters) to the action log.


    Having this setting checked meant that the parser settings seemed to have no affect whatsoever. 

    Thanks for your replies, they helped me narrow down the problem and figure it out.


    Kind Regards,

    Rich

Answers

  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    edited December 2018
    HI Richard

    Is it only email replies from a mobile?

    The exchange connector by defaults only attaches the message behind from: this works well for replies using outlook, not so great from other email clients.

    If someone replies from a phone for example, typically from: is missing and attaches the whole email thread.

    You could look to change the parsing key or encourage users when using a phone to insert from: at the end of a message.



  • Richard_ChalkerRichard_Chalker Customer IT Monkey ✭
    Hi Joe,

    Thanks for the reply, those are the settings that I needed and had no idea where to find or how to word it on google - I didn't do the original installation of SCSM. 

    The replies were from within outlook so it's strange that the parsing didn't take effect. Perhaps its because I'm testing it from my account which is set as an analyst (we're currently preparing SCSM before we migrate across). 

    I'll run a few more tests, this time with an account configured as an end user, and see how it goes. 
  • Tom_HendricksTom_Hendricks Customer Super IT Monkey ✭✭✭✭✭
    Also unsure why the From: token would not prevent that behavior (even multiple languages/character sets was not an issue for us when we used this connector), but this other thread might also be worth a look, if you find yourself needing more flexibility to tackle this.  https://community.cireson.com/discussion/2471/an-smlets-based-exchange-connector#latest
  • Richard_ChalkerRichard_Chalker Customer IT Monkey ✭
    Thanks Tom, I'll take a read over that tomorrow. 

    I've run a few more tests today with an end user account and it continues to keep the full email chain. 
    It might be that I need to delete the entire connector and set it up again to see if it takes the parser setting. 


  • Richard_ChalkerRichard_Chalker Customer IT Monkey ✭
    Accepted Answer
    Hi all,

    I managed to look into this a bit more today (been a bit busy leading up to Christmas) and found the option that was causing my problem. 

    My colleague who created the exchange connector had checked the box that says "Append the full body of the email message (up to 4,000 characters) to the action log.


    Having this setting checked meant that the parser settings seemed to have no affect whatsoever. 

    Thanks for your replies, they helped me narrow down the problem and figure it out.


    Kind Regards,

    Rich

This discussion has been closed.