IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

Cireson Portal + Response Time SLO

John_LongJohn_Long Customer Adept IT Monkey ✭✭
Just wondering is it possible to trigger the "first response" on a work item via the portal? I've added a comment to the work item via the "acknowledge" button and the "First response date" is now set. The response SLO still seems to be counting down in both SCSM and the portal itself.

Did I miss something?

Best Answer

Answers

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    It sounds to me like the SLO is not created correctly.
    If the First Response date is being set and the SLO is not acknowledging that the date has been set then I would check the SLO first.

    Have a look at the Metric that has been created and check that the start date is set to the "Created Date" and the end date is "First Response date".
    Also make sure the Queue that has been selected contains the IR that you are testing it on
    and finally that the SLO is enabled (Which it sounds like it is)

    My feeling is wither the Metric or the Queue is the issue.

    Good luck. I hope this has answered your question.
  • John_LongJohn_Long Customer Adept IT Monkey ✭✭
    @Brett_Moffett : Thanks for the quick reply!

    Metric is targeting class Incident with start date of "Created Date" and end date of "First response date".
    Metric shows as being related to my P4 Response SLO in the "Related SLO(s)" section.

    Work item shows the relationship changes as below. SCSM console shows the SLO as still active.
    Also in the history of the IR shows the relationship to the specific queue "V1 IT SLO - P4" being added.

    I'll mention that the IR is now part of two queues. One for the team who'll process them WI, one for the SLO. Hope that's ok?





  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    When you edit the IR form the console and you use the "Set First Response or Comment" task to set the first response, does the metric trigger then?

    From what I can see the portal is setting the First Response date fine so the Metric should calculate the time between the created date and the first response date and act accordingly.

    Can you post some screen shots here of your SLO and Metric just to rule out everything?
  • John_LongJohn_Long Customer Adept IT Monkey ✭✭
    No, when I set it via the SCSM console, the SLO remained in an Active state.
    Screenshots below.

    I'm also going to refresh the Health Service store on the primary workflow. Seeing manual activities not enter an In Progress state. Wondering if it's linked.


  • John_LongJohn_Long Customer Adept IT Monkey ✭✭
    Might have been related to workflows being stuck. Cleared out the cache and put the work item on hold and resumed. Bingo! Worrying though!

  • John_LongJohn_Long Customer Adept IT Monkey ✭✭
    @Brett_Moffett: thanks! I may inquire into that if this issue reoccurs.

    CPU utilisation on our primary workflow server is spiking to around 60% at night. Memory load also around the 60% mark. I don't include the workflow server in our web front end group to try and avoid resource issues.
  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    Also watch the IO.
    In my experience IO is the key piece that prevents the system from doing what it needs to do in enough time.
  • Peter_MiklianPeter_Miklian Customer Advanced IT Monkey ✭✭✭

    We have similar problem. @Tom_Hendricks explained in detail in my thread here: https://community.cireson.com/discussion/5046/sla-first-response-not-caught#latest

Sign In or Register to comment.