Home Advanced Send Email

Advanced Send Email and SCSM version 1801

Hello,

I'm having problems after upgrading SCSM to version 1801. When trying to send an email from the console, the following error occurs:

Date: 2018-11-16 12:05:05 Application: System Center Service Manager Application Version: 7.7.16.0 Severity: Error Message: Error System.NullReferenceException: Object reference not set to an instance of an object. at itnetx.consolemail.assembly.Classes.ConsoleMailWizardData.a.b(ManagementPackObjectTemplate A_0) at System.Linq.Enumerable.WhereEnumerableIterator`1.MoveNext() at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection) at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source) at itnetx.consolemail.assembly.Classes.ConsoleMailWizardData.GetNotificationTemplates(String templatePrefix) at itnetx.consolemail.assembly.Classes.ConsoleMailWizardData..ctor(WorkItemTypeEnum type, IDataItem& dataitemIncident) at itnetx.consolemail.assembly.Classes.ConsoleMailTaskHandler.ExecuteCommand(IList`1 nodes, NavigationModelNodeTask task, ICollection`1 parameters)

Has anybody else got the Advanced Send Email (3.0.2.2016) running in version 1801?

Regards

Marcus

Best Answer

  • Marcus_EhrnellMarcus_Ehrnell Member IT Monkey ✭
    Accepted Answer

    Hello,

    I got help from Cireson to find out about the problem. The problem was that one of the Notification Templates had no DisplayName and therefore the Advanced Send Email crashed. When I remove the template the problem disappeared.

    Regards

    Marcus

Answers

  • Marcus_EhrnellMarcus_Ehrnell Member IT Monkey ✭
    Accepted Answer

    Hello,

    I got help from Cireson to find out about the problem. The problem was that one of the Notification Templates had no DisplayName and therefore the Advanced Send Email crashed. When I remove the template the problem disappeared.

    Regards

    Marcus

  • Esben_HammerEsben_Hammer Member IT Monkey ✭
    I have the exact same issue, but I cannot find a template with no display name, so could it be caused by something else?

    Regards

    Esben
  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭
    @Esben_Hammer
    If you run this powershell do you get anything returned:
    Get-SCSMObjectTemplate | ?{$_.displayname -eq $null}
  • Esben_HammerEsben_Hammer Member IT Monkey ✭
    edited April 2019
    Well funnily enough:

    DisplayName Description ManagementPack                                                                    TimeAdded
    ----------- ----------- --------------                                                                    ---------
                            itnetX SCSM 'Advanced View Editor v2 Enterprise' License Information 13-02-2019...

    @Justin_Workman
  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭
    If you remove that management pack, that should clear up the issue with Send Email.  Obviously you have to weigh which bit of functionality is more important.
  • Esben_HammerEsben_Hammer Member IT Monkey ✭

    @Justin_Workman

    Yeah well we just bought and installed that, and it is more important, but I would obviously prefer to be able to use both..

  • Esben_HammerEsben_Hammer Member IT Monkey ✭

    In an earlier version it was possible to use both btw, we have done so for years..

Sign In or Register to comment.