Example: Change Requests with ARO



  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    edited November 2018

    We have been using the Change Request ARO for quite some time. It has worked with our SCSM 1801 environment very well for a long time. 

    Recently, I had to make some edits to one of our Change Request AROs. One of the fields was being multi mapped to the description already, but was needed in the title as well. So, I left the multi mapping alone in the description and added the multi mapping in the title as well. 

    However, when users now try to use this ARO, the multi mapping to the title and description do not work and both show up blank. I tried removing the multi mapping from the title and submitting a test request. It worked as it should. I then tried removing the field multi mapping from the description and putting it back in just the title. The test worked again.

    I had thought that my testing had succeeded, so I reported that the ARO was working and could be used again. Later that day, a user submits a Change Request with that ARO and experiences the same symptoms.

    I assume at this point it has to be some weird user error. I do a screenshare with the user so they can show me how they're using the request. They don't seem to do anything out of the ordinary and when they submit the request, all of the multi mapping shows in the Change Request like it should. 

    I am not seeing any logs out of the ordinary and there hasn't been any software updates before this started happening.

    If anyone has any experience with this, I'd really appreciate it.

    Thank you
    Hi Gary

    If using the template I created in the above MP - check for standard mappings. I believe I mapped title using standard SCSM mapping functionality. If both Multi Mapping and standard mapping is set it can cause weird issues.

  • Tom_HendricksTom_Hendricks Customer Super IT Monkey ✭✭✭✭✭
    Something that works for my team with a similar issue is opening the ticket template and clicking OK, then going back to the RO.  I have no idea why this works, but it consistently does, and not doing it consistently fails.
  • Gary_WinhovenGary_Winhoven Customer IT Monkey ✭
    Hey guys,

    Thanks for all the replies, but it turns out that the multi mapping to the description was going over the character limit for the field and that was causing the field to just come up blank.

    We ended up moving some of the less essential multi mapping to the notes and it seems to be working fine.

    Thanks again for your help!
  • Keren_MarroquinKeren_Marroquin Customer IT Monkey ✭
    I have a same issue but in my production environment the multiple mapping of all the fields show up blank.

    I have used the same MP en my test environment and Its working. Both of them environment have a same version .

    Could you help me? 
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭

    Closing thread as feature available out of box in ARO MP for portal v9.4.1+

    See for more info:


This discussion has been closed.