IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

Global Operators Group

Erin_MurphyErin_Murphy Customer IT Monkey ✭

In our SM Console, we have the Global Operators Group scoped to only analysts.
Does anyone know if there is a specific setting the Analyst Portal that brings across those settings?


Answers

  • Tony_CollettTony_Collett Cireson Support Super IT Monkey ✭✭✭✭✭
    As far as I'm aware, that setting should be scoped when the Cachebuilder runs if it's a part of the Analyst user role.
    What are you trying to achieve?
  • Erin_MurphyErin_Murphy Customer IT Monkey ✭

    We have the Global Operators group scoped to include dynamic members of specific departments.

    This eliminates the ability to assign jobs to people that aren't in those departments (i.e. staff who are not analysts), however in the portal, all users are able to be chosen to assign to.

    I would like the same settings in the portal if possible.

    We did have the 'assign to analyst by group' forced on, but we had complaints from staff that they couldn't reassign within their team without having to assign it to the support group again.

  • Brad_McKennaBrad_McKenna Customer Advanced IT Monkey ✭✭✭
    edited August 2016
    Erin, have you added the following code to your forms:
    FilterByAnalyst: true

    The code is necessary to seamlessly filter the Assigned To field to only Analysts, without using the Assign To Analyst by Group. 
  • Erin_MurphyErin_Murphy Customer IT Monkey ✭

    Hi Brad,

    Thanks for that. Yes, I do believe we have:
    Does it need to be set anywhere else?

  • Brad_McKennaBrad_McKenna Customer Advanced IT Monkey ✭✭✭
    To my knowledge, and in our instance, it only needs set in the one location.

    When you state all users can be chosen, is this all users in your CMDB? If not, could the users displayed that appear to be errant, possibly be granted Analyst rights unknowingly?

    A quick and easy check is the Stored procedure to check workitem permissions ensuring the individuals do not have the isAnalyst role unknowingly (https://support.cireson.com/KnowledgeBase/View/35)
Sign In or Register to comment.