Home General Discussion

Time in Change Request Saving to a Different Time

Alexis_StallmanAlexis_Stallman Customer IT Monkey ✭

In the portal when a user sets the planed start and stop time for a change request, if they save it and go back, the time is 5 hours behind the time they set. For example, if they set it to start at 6 am and end at 10 am, it would be saved as starting at 1 am and ending at 5 am. Once it is saved, you can go back in and change it and it saves correctly. Any ideas as to how to fix this?

Answers

  • Simon_ZeinhoferSimon_Zeinhofer Customer Advanced IT Monkey ✭✭✭
    edited May 30

    @Alexis_Stallman we have the same issue, when I have my date time settings set to german, it adds 2 hours to every date I map directly, when I have the settings set to english, the month and day values are swapped, which means every date where the day is above 12 throws an error in the log and is not mapped.

    We have an incident open for about 1 month now, with no feedback or whatsoever - To be honest I am a bit disappointed about that....

  • Alexis_StallmanAlexis_Stallman Customer IT Monkey ✭

    @Simon_Zeinhofer We have had an incident open for over a week as well and have also gotten no advice on how to fix it either. I am also disappointed about you having one open for a month, hopefully they get back to both of us soon.

  • Simon_ZeinhoferSimon_Zeinhofer Customer Advanced IT Monkey ✭✭✭

    @Alexis_Stallman I saw there is a Problem open for that case ;-)

    So I guess/hope, the problem will be solved in some of the next versions :)

  • Simon_ZeinhoferSimon_Zeinhofer Customer Advanced IT Monkey ✭✭✭

    @Alexis_Stallman John Doyle contacted me about that issue and he showed me a workaround which worked amazingly well.

    Do you still have that issue? If yes, I could write you the workaround :)

  • Alexis_StallmanAlexis_Stallman Customer IT Monkey ✭

    @Simon_Zeinhofer Yes, we are still having this issue, the workaround would be great! Thanks!!

  • Simon_ZeinhoferSimon_Zeinhofer Customer Advanced IT Monkey ✭✭✭
    edited July 7

    @Alexis_Stallman just for Info, I had to delete all my browser cookies, cache and so on so it worked. A Hard Refresh from my browser was not enough.

    Open the following file: C:\inetpub\CiresonPortal\Scripts\requestOffering\roService.js

    Change line 252 from:

    vm[i] = target.Content == "" ? null : kendo.toString(kendo.parseDate(target.Content), "g");

    to

    vm[i] = target.Content == "" ? null : vm[i] = target.Content;



    Then save the file

  • Alexis_StallmanAlexis_Stallman Customer IT Monkey ✭

    @Simon_Zeinhofer I will try it, thank you so much!

Sign In or Register to comment.