"propertyName" error when running "Update Software Asset" in console (view)

Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
Has anyone run into an issue wherein after creating a new Software Asset in the Console and then attempting to run "Update Software Asset" their presented with a bit of a stock SCSM management pack error of...

"Cireson Asset Management - propertyName"

It only happens from the view, but not from the asset. I'm being a bit bold here, but it feels like a bug in how IDataItem is being called to determine the context? If this is run from the portal, within the asset just a generic error is returned of "An error occured processing your request" with no further context in the description.

Best Answer

Answers

  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    Has anyone run into an issue wherein after creating a new Software Asset in the Console and then attempting to run "Update Software Asset" their presented with a bit of a stock SCSM management pack error of...

    "Cireson Asset Management - propertyName"

    It only happens from the view, but not from the asset. I'm being a bit bold here, but it feels like a bug in how IDataItem is being called to determine the context? If this is run from the portal, within the asset just a generic error is returned of "An error occured processing your request" with no further context in the description.

    Hi Adam,

    I think I may have seen this before and have reported it has a bug. Are you talking about the update software task from the console? Yet it works from opening the form?

    A screenshot would help me a lot on this one. 


    Merle
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    edited September 2016
    Merle, you're 100% correct in your observation/guess. The "Update Software Task" works on a Software Asset Form, but not within a Software Asset View.
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    I was searching the support KB for an Asset Related question when I noticed that the version history lists a new version (v7.5.60.146) of AM that includes this bug fix that was released several days ago (9.7.2016). However the software downloads page still reflects the old version (v7.5.60.144) of AM.
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    I see the version notes were since pulled from the KA on the Cireson support portal, are their plans for when this next release will be available?

    Additionally - is there an upcoming bug fix in said release that has anything to do with an error when creating a relationship between a location/subnet? In that if you try to add a Subnet from the Location form you receive a error, but if you try to add a Location from the Subnet form there isn't an issue?
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    I see the version notes were since pulled from the KA on the Cireson support portal, are their plans for when this next release will be available?

    Additionally - is there an upcoming bug fix in said release that has anything to do with an error when creating a relationship between a location/subnet? In that if you try to add a Subnet from the Location form you receive a error, but if you try to add a Location from the Subnet form there isn't an issue?
    Hello Adam,

    I've also noticed this as well. Let me pose this question to Dev and I will update you shortly

    Merle
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    Hey @merlenette_jones, I noticed the recent release of a bunch of Cireson console apps. While the majority focus on licensing, Asset Management features a pretty good set of fixes. Amongst them I noticed the propertyName on Software Update get addressed, but didn't see anything with respect to Subnet/Locations. Was this grouped into something else?
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    Hey @merlenette_jones, I noticed the recent release of a bunch of Cireson console apps. While the majority focus on licensing, Asset Management features a pretty good set of fixes. Amongst them I noticed the propertyName on Software Update get addressed, but didn't see anything with respect to Subnet/Locations. Was this grouped into something else?
    Hey Adam,

    Let me review the changes that were made and I will get back to  you with a full report on that. 

    Merle
Sign In or Register to comment.