IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

Change Request Action Log - potential issue?

Martyn_FearnMartyn_Fearn IT Monkey ✭Customer IT Monkey ✭

We have noticed an issue that may just be the way the portal works and if so we could have a feature request.

If the Analyst uses the 'Send Email' task within a CR the details get added to the Action Log correctly.  The issue occurs when the End User replies to that email.  The Exchange Connector appears to process it correctly and the email gets added as a Related Item of the CR.  However, nothing gets written to the Action Log.

Using the SCSM console we can see on the Extension tab of the CR form that the details have been written to 'Action Log' field.

Is this expected behaviour?

Is this an issue with the Exchange Connector?

Is this a feature request for the Analyst Portal?

Answers

  • Brett_MoffettBrett_Moffett Super IT Monkey ✭✭✭✭✭ Cireson PACE Super IT Monkey ✭✭✭✭✭
    Sounds like an issue with the Exchange Connector to me.

    When you say:

    Using the SCSM console we can see on the Extension tab of the CR form that the details have been written to 'Action Log' field.

    What do you mean by this?
    Are you talking about the History tab?
    Or is there another field that is appearing here?

    Any chance you can provide a screenshot?
  • Martyn_FearnMartyn_Fearn IT Monkey ✭ Customer IT Monkey ✭
  • Brett_MoffettBrett_Moffett Super IT Monkey ✭✭✭✭✭ Cireson PACE Super IT Monkey ✭✭✭✭✭
    @Martyn_Fearn this is the only place where the Action Log field is present within a CR.
    Where else are you expecting the e-mail to appear?
  • Martyn_FearnMartyn_Fearn IT Monkey ✭ Customer IT Monkey ✭

    Hi Brett,

    I was hoping it would appear as a End User Comment (similar to IRs and SRs) in the Action Log on the CR form.  This image is taken from an IR and it's this that isn't happening on the CR form.


  • Martyn_FearnMartyn_Fearn IT Monkey ✭ Customer IT Monkey ✭
    Does anyone have any thoughts on this?
  • Tom_Vidar_NøklebyTom_Vidar_Nøkleby IT Monkey ✭ Customer IT Monkey ✭
    We are having a similar problem. Email sent to a change does not appear any place in the change. The only thing it does is add the email_workflow account as related item. Isn't it odd that there isn't any way to communicate through a change request. how are other people handeling this?
  • Brett_MoffettBrett_Moffett Super IT Monkey ✭✭✭✭✭ Cireson PACE Super IT Monkey ✭✭✭✭✭
    Hi @Martyn_Fearn
    In a previous post you wrote:

    I was hoping it would appear as a End User Comment (similar to IRs and SRs) in the Action Log on the CR form.  This image is taken from an IR and it's this that isn't happening on the CR form.

    As CR's are not usually for the consumption of end users, they are usually an internal IT process, there is no real relevance in tracking the difference between end user and analyst comments as they should all be analyst comments.
    If you are using CR work items to involve end users within the business then this either might need to be a custom solution (New type of relationship added to the CR class) or a change in the process that your company uses.

    I hope this has answered your question.
  • Brett_MoffettBrett_Moffett Super IT Monkey ✭✭✭✭✭ Cireson PACE Super IT Monkey ✭✭✭✭✭
    Hi @Tom_Vidar_Nøkleby
    E-mail responses to a change should appear in the extensions tab under the title of Action Log



    The fact that an e-mail to a CR is triggering the addition of a relationship to the Workflow account seems odd to me and I can't explain what it is that is doing this piece.
    Are you able to investigate what or who is adding this relationship by looking at the CR history?
  • Tom_Vidar_NøklebyTom_Vidar_Nøkleby IT Monkey ✭ Customer IT Monkey ✭
    Hi. @Brett_Moffett
    Thanks, i found the action log .
    About the relationship, the history shows this:


    The creator of this entry is the email-workflow account. It is also the Iitem related under relationship changes.

  • Martin_StrbavyMartin_Strbavy IT Monkey ✭ Member IT Monkey ✭
    Hi @Brett_Moffett @Tom_Vidar_Nøkleby, was this issue fixed in SSP or somewhere? We are currently running older version of SSP (currently working on upgrade) and we are having same issue. When created by user will reply to ticket, message is added to related items, but not to action log in SSP. But History tab is showing that it was added to Action Log.

    Thanks
Sign In or Register to comment.