IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

Dashboard "Caching"

Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
I have some dashboards from management that the support teams work hard to make sure they do not show up on these reports.
We have noticed in recent (so cannot relate to specific portal version) that the dashboard seems to get cached. 
IE work item IR123 was on the report for missing a support group assignment.
Opened the work item and assigned to a support group
Returned to the dashboard and work item was still listed.
Waited 5 minutes for background workflows to run but item remained on report
Until the browser was closed and reopened the dashboard did not update
But once browser was reopened work item cleared from report. 

Portal v7.4.2012.3
IE 11

Wondering if others are seeing this. 

Best Answer

  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    Accepted Answer
    Discovered that 7.4.2012.9 resolves this issue.

Answers

  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    And of Note tested in Chrome and do not have that issue. Dashboard instantly updates.
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    @Brian_Wiest

    Exactly which Dashoboard are you using. I'm getting similar behavior with but I want to know what Dahboard this is specifically
  • Leigh_KildayLeigh_Kilday Member Ninja IT Monkey ✭✭✭✭
    I had this issue with IE because it was set to IE 10 compatibility mode. Setting it to "Edge" compatibility mode fixed it
  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    I am using IE 11 native mode.
    Getting the issue on all dashboards
    Reason for issue if you review the getdashboarddata header Cache-control is set to private. Needs to be turned off.
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    I am using IE 11 native mode.
    Getting the issue on all dashboards
    Reason for issue if you review the getdashboarddata header Cache-control is set to private. Needs to be turned off.
    Hello Brian,

    At the moment this is the expected behavior.
  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    Accepted Answer
    Discovered that 7.4.2012.9 resolves this issue.
Sign In or Register to comment.