Home Advanced Request Offering

After updating an ARO can no longer edit it

Eric_KrasnerEric_Krasner Customer Advanced IT Monkey ✭✭✭
When trying to edit an ARO after adding additional prompts, i get the following error message.  Has anyone seen this?

Message: Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).

Best Answers


  • Peter_SettlePeter_Settle Customer Advanced IT Monkey ✭✭✭
    Have you attempted to Copy or Duplicate the ARO instead of editing it.
  • Eric_KrasnerEric_Krasner Customer Advanced IT Monkey ✭✭✭
    I tried that and it didn't work.  I got the same error message when trying to "Edit Advanced Request Offering."  Funny thing is that I can edit it as a normal RO, just not as an ARO.
  • Eric_KrasnerEric_Krasner Customer Advanced IT Monkey ✭✭✭
    I figured that was where I was at.  Was just trying to avoid the inevitable. On a side note, it would be great if there was a way to remove the standard Edit RO from the double click action on the RO and replace it with the Edit ARO action.  Would solve alot of headaches.
  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    I agree @Eric_Krasner
    We have tried many different ways to remove the default editor and\or remap the default double click method against request offerings but there is no supported way to do so.
    Could we hack the whole thing? Maybe. But then it would invalidate the Microsoft support of the entire SCSM product.

    Really sorry that this is the way it is and we certainly wish we could do more to make this easier for people.
Sign In or Register to comment.