Home Service Manager Portal Feature Requests
We appreciate you taking the time to vote and add your suggestions to make our products awesome! Your request will be submitted to the community for review and inclusion into the backlog.

We recommend reviewing what is submitted before posting, in case your idea has already been submitted by another community member. If it has been submitted, vote for that existing feature request (by clicking the up arrow) to increase its opportunity of being added to Cireson solutions.

For more information around feature requests in the Cireson Community click here.

Don't add all / new AD-groups to 'Assigned AD Groups' in navigation settings

When configuring the 'Assigned AD Groups' for new or existing pages, newly imported AD-groups get added to the list of assigned groups. This is a bit counterintuitive behavior, as the access to the page is meant to be restricted to the selected groups, and should not be altered implicitly.

The same goes for when going from public to not public, as all AD-groups are added to the list, and needs to be removed one-by-one (or directly in the DB).

So new AD-groups should not be added to the 'Assigned AD-Groups' list, and all AD-groups should not be added by default, when configuring a page.
10 votes

Submitted · Last Updated

Comments

  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    Agreed or some control in settings with True/False if you want it. Preferable per navigation page so global pages have a check box so it can still auto add. 
  • Konstantin_Slavin-BoKonstantin_Slavin-Bo Customer Ninja IT Monkey ✭✭✭✭

    Any news on this? I still have to regulary check assigned AD-group for all navigation items regulary, to ensure that no unintended group has access.

  • Dean_LinternDean_Lintern Customer IT Monkey ✭
    edited February 19

    Also having this issue, has anyone had any resolution?

  • Konstantin_Slavin-BoKonstantin_Slavin-Bo Customer Ninja IT Monkey ✭✭✭✭

    Nope, I still haven't heard anything.

  • Gabriel_LencesGabriel_Lences Customer Advanced IT Monkey ✭✭✭

    Bump, this is just logical to not 'auto-add" AD groups to navigation views. Plain and simple as that.

  • Peter_MiklianPeter_Miklian Customer Advanced IT Monkey ✭✭✭

    This is very awkward and confusing. I was wondering why I have some groups in navigation folder permission, removed them and after some time I see them there again 😩

    Do something about it, I beg you 🙏

  • Brad_ZimaBrad_Zima Member IT Monkey ✭

    Yeah, this is quickly becoming a problem for me as I add more pages to the portal, especially ones with semi-sensitive information suddenly becoming visible to groups that have no business seeing them.

  • Gabriel_LencesGabriel_Lences Customer Advanced IT Monkey ✭✭✭
    edited June 2

    So just so the Cireson guys can replicate this problem (feature? bug?), the most easiest way to replicate this is actually create a new blank page in the navigation node. Restart the cache builder - wait a while. Viola, even though you didn't assign any AD groups to the new blank page (you only create it and then go restart the CB) - It auto-fills a whole lot of AD-groups. I think this also happens even if you create it and assign the groups to the navigation view you created and then restart the CB, it adds additional groups there. This is becoming more and more frustrating for us as well since we just started to include our Org. branches into our system.

    This needs to be definitely fixed.

    @Cireson if any of you guys want to replicate this problem with me, just grab me up for a call, I can show this to you.

  • Brad_ZimaBrad_Zima Member IT Monkey ✭

    Yeah, I would almost consider this to be a bug at this point since the groups come back every time the Cachebuilder service is restarted.

  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭

    Thanks guys. @Gabriel_Lences - I have reproduced with your steps above. We're taking a look at this.

    @Steve_Wright - FYI

Sign In or Register to comment.