Asset Managment Import - Error when importing data into Standards

Jarrett_FaulkJarrett_Faulk Customer IT Monkey ✭
Hello Everyone,

I am attempting to import some information into the Asset Management Standards.  I am using the Asset Management Import Connector and a simple SQL query.  When I synchronize the connector it reports a status of Finished With Error and 0 percentage.  The logs are showing an error that states: "Error - Id_53988D04_D851_BCE9_8DBF_CC06EBBA3761='174' -- Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)."

The Data Mappings is showing this ID field as a required property but I am uncertain as to what information it needs. 

Has anyone else experienced this issue?

Thank you in advance for any assistance.

Best Answer

Answers

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    The Asset ID is a required field and you can use a randomly generated GUID here, or you can assign a number that you wish to it.

    Some places use the Asset Tag as the Asset ID.
    However, if you ever "Reuse" asset tags for replacement items or repaired items etc, then this can cause issues.
    So a randomly selected GUID is best in a complex environment.

    In My Honest Opinion, Best practice would be to NEVER reuse Asset Tags and use the Asset ID as the Asset Tag.

    I hope this has answered your question.
  • Jarrett_FaulkJarrett_Faulk Customer IT Monkey ✭
    @Brett_Moffett

    Thank you for this information.  I've been attempting to get the import to assign a random GUID but I must be missing the option somewhere.  I guess i'm not understanding what I should map to the ID property.  I've imported other data using the same method and have not had any issues.

    Thanks again.
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Hi Jarrett,

    Unlike most of the Cireson Asset Management Administration items, Standards use a GUID, 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx), for the primary key field. Hardware and Software assets do too (along with most othe items in SCSM).

    Therefore you need to have a column full of randomly generated GUIDs in your CSV file in order to import.

    The easier way I know to do this is with PowerShell.

    1..10 | ForEach-Object { [guid]::NewGuid() }

    will spit out 10 GUIDs. Copy and paste these into your CSV file and then choose this column for the ID property when configuring the connector.

    Geoff
Sign In or Register to comment.