Home SMA Connector

SMA connector stopped working due to "The location monitoring object is not managed" error

Tomi_KaartamaTomi_Kaartama Customer IT Monkey ✭
The SMA connector suddenly stopped working in our environment producing the "The location monitoring object is not managed" error for data access services. The connector license is valid. The full error is:

The database subscription is unable to trigger the Windows workflow because of Data Access service errors.
 The following errors were encountered:
 Exception message: The location monitoring object is not managed.
One or more subscriptions were affected by this.  

Subscription name: Microsoft.EnterpriseManagement.ServiceManager.Connector.SMAConnector.RunbookMonitorRule 
Instance name: Microsoft.EnterpriseManagement.LinkingFramework.SCOConnector.MonitoringWorkflowTarget 
Instance ID: {5312E86C-61D6-9AA1-1F58-A3DA08F813F7} 
Management group: *****

Any ideas how to fix this?

Best Answers


  • seth_coussensseth_coussens Member Ninja IT Monkey ✭✭✭✭
    When you say suddenly stopped, what other changes occurred in the environment? Any changes to SMA itself or the servers running SMA or Orchestrator? Any changes to the SCSM workflow server itself or database upgrades? AD?

    Seems like something changed on the SMA side for the runbook monitoring rule to have an issue.
  • Tomi_KaartamaTomi_Kaartama Customer IT Monkey ✭
    This is our staging environment so it is not in daily use. As far as I can see, everything was working fine at least on Dec 1st when SMA runbooks were triggered as they should. The issues were noticed only on Dec 13th when we were deploying changes to our production environment and had to check something from staging. Between these dates, I am now aware of any changes in the staging environment, not even patching. 

    Unfortunately the Operations Manager log has been overwritten so no help from there. Application log does not seem to have anything that would explain this.

    If I were to look for events on the SQL server or SMA server, any ideas which event logs to search?

    I've also opened a ticket on the Cireson support portal. Ticket # is IR59874.

    T: Tomi
  • seth_coussensseth_coussens Member Ninja IT Monkey ✭✭✭✭
    Have you tried stopping the Monitoring Agent service, clearing the HealthState folder from SCSM, and then restarting the monitoring agent? If no dice there, how about removing and re-adding the SMA connector itself?
  • Tomi_KaartamaTomi_Kaartama Customer IT Monkey ✭
    Did not work. However, I only added one extra SMA connector and modified the workflow to use that connector instead. Still having this kind of warnings in event viewer:

    Data Access Layer rejected retry on SqlError:
     Request: UpdateAvailability -- (BaseManagedEntityId=067ef8e2-e828-0133-4bd3-104e317707e7), (IsAvailable=True), (ReasonCode=0), (TimeGenerated=1/11/2017 7:09:20 AM), (RETURN_VALUE=1)
     Class: 16
     Number: 777980050
     Message: Cannot set availability on a health service that doesn't exist.
  • Tomi_KaartamaTomi_Kaartama Customer IT Monkey ✭
    I have tried now to remove the SMA connector and recreate it. However, there is a "ghost" SMA connector displayed that I cannot remove. It is visible in the connector list but it is not available when configuring the actual workflows. There is also no option to delete the connector. When selecting the connector, the only available tasks are shown the attached image.

    Any ideas on how to get rid of the ghost connector and whether it could be the root cause of the issues?
  • seth_coussensseth_coussens Member Ninja IT Monkey ✭✭✭✭
    edited January 2017


    Q: I have an orphaned Exchange connector in Service Manager 2012. How can I delete it?
    A: It's possible you had been using the Exchange Connector RC and just installed the RTM version without first deleting the old connector and uninstalling the old code. You would then be left with an Exchange Connector that couldn't be used or deleted. Your first instinct might be to try and delete it using the native Windows PowerShell:
    Are you sure you want to perform this action?
    Performing operation "Remove-SCSMConnector" on Target "SAVDALEX01 Exchange
    [Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help
    (default is "Y"):Y
    Unfortunately, the command above doesn't actually delete the connector. We therefore have to fall back to the SMLets, which are available at Codeplex.  They were originally written for Service Manager 2010. Download and install the SMLets, then perform the following:
    <strong>PS C:\> Import-Module smlets<br></strong><strong>PS C:\> Get-SCSMObject –Class (Get-SCSMClass –Name Microsoft.SystemCenter.Connector) | ?{$_.DisplayName –eq “SAVDALEX01 Exchange Connector”}<br></strong><strong>ClassName DisplayName LastModified<br></strong><strong>--------- ----------- ------------<br></strong><strong>Microsoft.SystemCenter.Connector SAVDALEX01 Exchange Connector 4/29/2013 1:16:53 PM<br></strong><strong>PS C:\> Get-SCSMObject –Class (Get-SCSMClass –Name Microsoft.SystemCenter.Connector) | ?{$_.DisplayName –eq “SAVDALEX01 Exchange Connector”} | Remove-SCSMObject -Force -Confirm</strong>
    The connector should now be gone. The big difference between the SMLets Remove-SCSMObject and the 2012 built-in Remove-SCSMConnector is that the Remove-SCSMObject has a -Force option.

    <strong>Get-SCSMObject –Class (Get-SCSMClass –Name Microsoft.SystemCenter.Connect<pre class="CodeBlock"><code>or) | ?{$_.DisplayName –eq “SAVDALEX01 Exchange Connector”} | Remove-SCSMObject -Force -Confirm
  • Tomi_KaartamaTomi_Kaartama Customer IT Monkey ✭
    edited January 2017
    OK, connector removed. One modification was required to the command. Instead of using "Microsoft.SystemCenter.Connector"&nbsp;I had to add the dollar sign like this "Microsoft.SystemCenter.Connector$". Connector is gone, now I'll try to set up a new connector and see if the root cause is resolved.
  • seth_coussensseth_coussens Member Ninja IT Monkey ✭✭✭✭
    Ok, glad you figured it out and have everything up and running again. Sorry for all the trouble, but this is the first I've heard of that particular issue. Hopefully this thread can help someone else if they run into the same issue.
Sign In or Register to comment.