SCSM 2016 Errors for Cireson Console Apps

Adrian_PaechAdrian_Paech Customer Advanced IT Monkey ✭✭✭

Hi All,

I have just upgraded our development SCSM environment (in-place) to 2016, the portal (6.0.3) works great, however, I am getting the error below when trying to open the settings on all of the Cireson console applications. (including the portal group mapping settings for v6.0.3 of the portal)

I have upgraded to the latest version of all the apps, but still get the same result.
I gather all of the Cireson console apps need to be recompiled with .Net 4.5?

Alternatively, is there something I can do to get these apps working, or do I just need to wait for a new (2016 compatible) version of console apps to be released?

If so, what is the ETA on this?

Alternatively, if there is an unreleased (recompiled) version which supports 2016, I am happy to be a tester, if this is any help to the Cireson team?

Reported Error:

Kind Regards,

Adrian

Best Answer

Answers

  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    edited October 2016

    I have upgraded to the latest version of all the apps, but still get the same result.
    I gather all of the Cireson console apps need to be recompiled with .Net 4.5?

    Alternatively, is there something I can do to get these apps working, or do I just need to wait for a new (2016 compatible) version of console apps to be released?

    As far as I know new SCSM 2016 compatible MPs aren't out and per the roadmap documentation I haven't seen anything updated. The portal (v6+ or v6.0.1+ I think is what allows for the 2012r2/2016 cross compatibility).

    Truthfully, I'm responding because I wouldn't mind hearing how your in-place dev upgrade went. If your original post is any indicator it sounds as though it wasn't anything troublesome?
  • Adrian_PaechAdrian_Paech Customer Advanced IT Monkey ✭✭✭
    edited October 2016
    Thanks Shaun!
    Appreciate the feedback.
    looking forward to the updates :)

    Hey Adam, yes the in place upgrade went smoothly. All my customisations worked fine. (Custom workflows which call custom written powershell scripts, form customisations etc.) Also the the portal seemed to behave ok, although I did notice that the dashboards seemed to report incorrect information.
    as discussed above, all Cireson based customisations in the console stopped working, but this is to be expected, and looks like it will be resolved with the next update :).
    Cheers,
    Adrian

  • Adrian_PaechAdrian_Paech Customer Advanced IT Monkey ✭✭✭

    Just a minor one (for Cireson developers to note).

    I have noticed in SCSM 2016 that request offerings drop off in the portal, and you have to restart the cachebuilder to ensure they come back. This happens every few hours.


    Regards,

    Adrian

  • Tony_CollettTony_Collett Cireson Support Super IT Monkey ✭✭✭✭✭

    Just a minor one (for Cireson developers to note).

    I have noticed in SCSM 2016 that request offerings drop off in the portal, and you have to restart the cachebuilder to ensure they come back. This happens every few hours.


    Regards,

    Adrian

    Thanks, we'll keep this in mind when testing the 2016 version for the Cireson Portal. Is there anything triggering the lost RO's or does it just happen randomly?
  • Adrian_PaechAdrian_Paech Customer Advanced IT Monkey ✭✭✭
    Just happened randomly a couple of times.
    it hasn't happened for a couple of days now. But I will keep an eye on it.

    Regards,
    Adrian
Sign In or Register to comment.