IT Monkey:   Join the Cireson Community today for your chance to win $50!

Session Timeout

Kevin_GoodwinKevin_Goodwin Customer Adept IT Monkey ✭✭
I am wondering if anyone else is experiencing what I am seeing. We are on version 8.2 of the analyst portal and we have auto logins enabled through AD. There is a session timer set to 60 minutes, but I am finding that the session will try and time out only moments after I stop working at times. I haven't caught anything on a timer yet, but it seems to go for an hour no matter what, and then at the end of that hour, you get the timeout notification with the option to renew. Is the portal not sensing activity and resetting the timer or do I have something setup incorrectly?

Best Answers

Answers

  • Matt_MedleyMatt_Medley Cireson Support Advanced IT Monkey ✭✭✭
    Hey Kevin, when you say that the session will try and time out only moments after inactivity, what are you seeing during that attempt? Do you get the timeout notification with the renewal option?
  • Kevin_GoodwinKevin_Goodwin Customer Adept IT Monkey ✭✭

    Yup, I get the renewal option. It has happened to a couple of my analysts while they are adding a note to a ticket.

  • Matt_MedleyMatt_Medley Cireson Support Advanced IT Monkey ✭✭✭

    Yup, I get the renewal option. It has happened to a couple of my analysts while they are adding a note to a ticket.

    Do you have a GPO in place that controls session timeout for Windows? 
  • Kevin_GoodwinKevin_Goodwin Customer Adept IT Monkey ✭✭

    No GPO's that I am aware of. We have the auto-lock setup for workstations if there is no activity for 20 minutes, but that shouldn't be causing anything.

  • Kevin_GoodwinKevin_Goodwin Customer Adept IT Monkey ✭✭

    Oh I think I have an idea that just clicked in my head. I have the following set in the admin settings:

    ServiceManagerInactivityTimeoutMinutes                 60

    SessionTimerCountdown                                          180

    UserTokenExpirationMinutes                                    60

    UseSessionTimer                                                      True


    If I set UseSessionTimer to 'false' would that solve my problems?

  • Matt_MedleyMatt_Medley Cireson Support Advanced IT Monkey ✭✭✭

    Oh I think I have an idea that just clicked in my head. I have the following set in the admin settings:

    ServiceManagerInactivityTimeoutMinutes                 60

    SessionTimerCountdown                                          180

    UserTokenExpirationMinutes                                    60

    UseSessionTimer                                                      True


    If I set UseSessionTimer to 'false' would that solve my problems?

    Good catch there, setting it to 'false' should resolve the issue.
  • Brian_WiestBrian_Wiest Customer Ninja IT Monkey ✭✭✭✭
    Doesn't setting the UseSessionTimer = False just fully disable the interactive timer dialog box?
    Meaning the portal falls back on basically why the timer dialog box was added. Where the service account performs the actions in the work item history after a user times out. 

    I was able to modify my timer to 25 minutes but I also had to make the change in IE session settings
    So for me it look like

    ServiceManagerInactivityTimeoutMinutes                 60
    SessionTimerCountdown                                          300
    UserTokenExpirationMinutes                                    25
    UseSessionTimer                                                      True



    This provides me a 20 minute session and then a 5 minute window of the dialog box counting down. Keeping my security group happy. 

    Down side is each upgrade I have to reset these values. 
  • Kevin_GoodwinKevin_Goodwin Customer Adept IT Monkey ✭✭

    So I did some testing this morning, and I came up with various results...

    Opened the portal and left it alone while working on other windows on the same workstation - session timeout at ~17 minutes

    New session, left alone for 8 minutes, then opened a ticket, session timed out ~ 17 minutes after opening the ticket

    Left the portal alone again and got a timeout again around 17 minutes.

    I then closed the portal and re-opened to and intended to keep the portal active with some sort of activity up to an hour. I had a ticket open, started adding a note, went to a different application briefly and saw the portal timeout. This happened at ~ 22 minutes with my last activity working that ticket having occurred ~ 2-3 minutes ago.


    I checked all of the timeout settings I could find in the App Pool and IIS, they all say 20 minutes. I was expecting to be able to keep the portal active for 60 minutes before seeing the UserTokenExpirationMinutes take hold at 60 minutes.

    Not sure if this sheds any light, cause it only left me with more questions, haha.

  • Kevin_GoodwinKevin_Goodwin Customer Adept IT Monkey ✭✭
    Thanks for the help guys. I adjusted the time settings and we are not getting the timeout message as often anymore.
  • Steve_ClarkeSteve_Clarke Customer Adept IT Monkey ✭✭
    @Brian_Wiest can you confirm that setting the UserTokenExpirationMinutes to 65 does not result in the issue with the history being reported as the service account re-occuring?
  • Brian_WiestBrian_Wiest Customer Ninja IT Monkey ✭✭✭✭
    I cannot directly confirm at 65. As my security guys only allow me 25. But I can confirm at the 25 mark the user account is still writing the updates. The key is to keep all the different values in line of each other.
  • Steve_ClarkeSteve_Clarke Customer Adept IT Monkey ✭✭
    ok thanks, I might push it to 25 just to be safe and do some further testing myself in our test envionment. 

    @Kevin_Goodwin you might just want to keep an eye on the History tab of your work items and make sure it doesnt start showing changes being performed by the Service Account instead of the Analyst who actually performed the change. 
  • Kevin_GoodwinKevin_Goodwin Customer Adept IT Monkey ✭✭
    @Steve_Clarke will do. I was not a fan of that happening before.
Sign In or Register to comment.