Cireson service manager portal not syncing with service manager

Daniel_ClarkeDaniel_Clarke Customer IT Monkey ✭
Hi, I have an issue where the Cireson database is not syncing with the service manager database. The service manager console and database show all new requests created in the Cireson portal and via email (we have this setup so emails to IT automatically create requests). However, the Cireson portal and database only show new requests created in the portal and no emails to IT are creating requests. 

I'm running the latest Cireson portal, I have checked permissions on the database and folders, I have have restart the server and cachebuilder, I have re-synced the AD connector, I have re-installed the portal, I have truncated the database, I have compared an old CacheBuilder file to the new one and it is the same. I do have errors in the CacheBuilder log file which might help someone give me a resolution:

2017-12-08 15:43:24,805, ERROR [  16]:  Error:
A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The specified data could not be decrypted.)
2017-12-08 15:43:24,852, ERROR [  16]:  Unable to sync SCOPED ACCESS, the operation failed permanently. Please review the log for errors, correct them, then restart the cachebuilder service.
2017-12-08 16:27:39,746, ERROR [   4]:  Error connecting to management server: The Data Access service is either not running or not yet initialized. Check the event log for more information.

Any help would be greatly appreciated.

Answers

  • Tony_CollettTony_Collett Cireson Support Super IT Monkey ✭✭✭✭✭
    Hi Daniel, 
    The biggest concern is that emails to IT are not being created; this, combined with the third error "The Data Access service is either not running or not yet initialized." points us to an issue in the SCSM console rather than on the portal itself. 
    Have you tried restarting the data access services on the service manager server?
    The following services should be restarted: System Centre Data Access Service, System Centre Management Configuration and Microsoft Monitoring Agent. 
    After this, wait for a few minutes and try emailing IT again and see if it creates a ticket. 

    If you are still having issues, check to see if your workflows are running correctly - i.e. are any new service requests entering a 'In Progress' state when they are newly created, or are they stuck in New? Stuck in New means you may need to look at support from Microsoft
  • Daniel_ClarkeDaniel_Clarke Customer IT Monkey ✭
    Thanks for the reply Tony. I had restarted the services you mentioned but that didn't help either. The requests are going to Submitted which is how it has always worked.
    I can see the email requests in the Service Manager DB but not the Cireson DB. Also, if a request is created in the Cireson Portal, it shows up in both databases. It's as if there is only one way communication between the databases but the security/permissions are the same for both.

    Anymore help would be grateful.
  • Tony_CollettTony_Collett Cireson Support Super IT Monkey ✭✭✭✭✭
    In the Cachebuilder Service Settings, can you check that the Log On tab has the correct information?
  • Daniel_ClarkeDaniel_Clarke Customer IT Monkey ✭
    It does but I re-entered the password again and re-started the service just to confirm.
  • Daniel_ClarkeDaniel_Clarke Customer IT Monkey ✭
    OK. Our DB Admin found the issue. I will post more tomorrow in case anyone else has this issue but it has to do with the SQL Server Agent Job 'Cireson Update Existing Service Requests' failing.
  • Daniel_ClarkeDaniel_Clarke Customer IT Monkey ✭

    More detail: We added the bold line below to the Cireson Update Existing Service Requests SQL agent job. Basically it’s processing only service requests and ignoring other type of requests now. Without this line it fails. Our emails are submitted as service requests and not incidents so this change doesn't affect us but it might affect you if the emails are also submitted as incidents:

    left join [ServiceManagerCireson2016].[dbo].DisplayString UrgencyDS

                  on WI.Urgency = UrgencyDS.ElementID and UrgencyDS.LocaleID = ISNULL(@locale, 'ENU')

                  WHERE WI.LastModified > [SM_WorkItem_ServiceRequest].LastModified

                  AND WI.ClassID = '04B69835-6343-4DE2-4B19-6BE08C612989'

  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭
    @Daniel_Clarke While your DB admin found an error with the SQL jobs, those jobs are specific to the replication of content to the Analytics database. They are not part of the cachebuilder service that populates SCSM to the Cireson DB. 

    I have also run into the issue with scope access failure. If it keep occurring after a restart of the cachebuilder, up the logging level and see what it is failing on. For me in most cases I have had to run a full AD sync in SCSM to clear the error. 
  • Daniel_ClarkeDaniel_Clarke Customer IT Monkey ✭
    Hi Brian, thanks for your response. It is strange that as soon as that SQL job was changed, the error went away and everything started working again. I had previously worked on the issue for a week which included re-installing and re-syncing the AD and that didn't resolve the issue. The databases starting syncing after the change so is it possible that this sync reflected on the portal page?
Sign In or Register to comment.