Home Orchestrator

Runbook Error - "The property SCObjectGuid is not valid for the given criteria."

T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭
edited January 19 in Orchestrator

Hi everyone, I've been dealing with this for a while now, and I'm finally at the point of reaching out for any assistance. I've configured a SCOM alert to trigger an IR in SCSM, and that IR has an RB Activity.

This is my current issue:

The Initialize Data step produces the GUID I'm looking for, and I'm using the Get Relationship to go from a Runbook Activity to a SCOM Generated Incident.

The Get Relationship, while showing a "success" status, doesn't return any objects.

If I do an SMlets search for the GUID, nothing returns:


I've been pouring over permissions and finding a very limited amount of articles that talk about this error, but nothing has helped so far.

Has anyone else experienced this before?

Here's the screenshots of the flow (the link conditions are unchanged from default):


Thanks for any help in advance.

Best Answer

  • T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭
    Accepted Answer

    Ok, self-update, I figured this out, in case anyone else runs into this. Your Orchestrator Integration Pack for Service Manager account must be an administrator in the Service Manager environment you're targeting. This was all user error, as I had made the right moves in dev, but accidentaly flipped two groups in prod, so this account wasn't treeing up properly. All fixed!

Answers

  • T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭
    Accepted Answer

    Ok, self-update, I figured this out, in case anyone else runs into this. Your Orchestrator Integration Pack for Service Manager account must be an administrator in the Service Manager environment you're targeting. This was all user error, as I had made the right moves in dev, but accidentaly flipped two groups in prod, so this account wasn't treeing up properly. All fixed!

  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭

    Ahh, nice find.

  • John_BeasleyJohn_Beasley Customer IT Monkey ✭

    I get this anytime i create a runbook and look for activities. Its the simpleist of Runbooks too. I have checked for the User account and its got the permissions so Im not sure what to do. It always fails.

Sign In or Register to comment.