Hiding buttons from the drawer

Eugene_RackEugene_Rack Customer IT Monkey ✭
Good afternoon

Can you hide buttons from the drawer menu by using a .js file? For instance when selecting Drawermenu - New - Workitem - Inicident - QuickCreate, can the quick create be hidden via a .JS file? I know that there is an article that says updating the .css file can do it but was wondering if there is another method of hiding drawermenu items?

Answers

  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭
    This will hide Quick Create for incidents:
    $('[data-click-template="incidentQuickAdd"]').hide()

  • Eugene_RackEugene_Rack Customer IT Monkey ✭
    @Justin_Workman ;

    Hello Justin
    Is that command in the custom.js? 
  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭
    You can add it to custom.js.  You might want to make wrap it in a document ready function like this:
    $(document).ready(function() {$('[data-click-template="incidentQuickAdd"]').hide()})
  • Eugene_RackEugene_Rack Customer IT Monkey ✭
    @Justin_Workman ;

    Thanx for the update Justin. This is strange one for our setup. A while back we hid the Quick create and Change Request options. Last year about August time we had SCSM 2016 installed on new servers and migrated the work items and custom.js amongst other files. I have checked our .css files and the custom.js but cannot see the settings to hide the Quick create and Change Request items via the DrawerMenu New work items.


  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭
    You can change who sees Change Request from the +New menu by adding a group in Admin Settings/Work Item settings.  You can also set 'showQuickCreateForIR' to false in Admin Settings/Setting Items
  • Eugene_RackEugene_Rack Customer IT Monkey ✭
    @Justin_Workman ;

    Thanx very much for that. For some reason I did check Admin settings and saw that we had false for Quickcreate. Not sure why I did not check that first. Sorry. Also the Create Change request I needed the CacheBuilder to run first for that one to show.

    Thanx for all your help
Sign In or Register to comment.