IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

SQL Widget - Column Alias

Jamie_EsquivelJamie_Esquivel Customer IT Monkey ✭
Looks like when adding new pages with a SQL widget, it won't allow column aliases with spaces in them. Is this a known bug?

Comments

  • Jamie_EsquivelJamie_Esquivel Customer IT Monkey ✭
    To clarify, this is the column alias in the actual SQL query. Example 'Affected Department' won't work but 'AffectedDepartment' will work
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Hi Jamie, I think putting the alias in [] will work.
  • Jamie_EsquivelJamie_Esquivel Customer IT Monkey ✭
    I tried that but when I use the brackets the query will return 0 rows. Geoff_Ross said:
    Hi Jamie, I think putting the alias in [] will work.

  • Brian_WinterBrian_Winter Customer Adept IT Monkey ✭✭

    I'm running into a similar problem. Given

    SELECT au.Department as [Affected User Department] .....

    I cannot get the Spaces to display. I've also tried single quotes and compressing it to a single CamelCase word.

    Seems that only canned column names (i.e. Affected User, Support Group, Assigned To, etc.) are the only ones that work. Custom column names don't. (or I can't find a solution).

Sign In or Register to comment.