IT Monkey:   Join the Cireson Community today for your chance to win $50!

Any Reason For Completion Date To Be Null?

Bryan_SchrippeBryan_Schrippe Premier Partner IT Monkey ✭
All,

I'm having an odd issue with surveys.  In the survey section of the app we have 2 completed surveys. In the database MTV_Cireson$Survey$Result, one has a correct completed date, and the other does not.



Sadly this is throwing off my BI data as were looking to max completion date. Since there is no method to stop a user to complete a survey more than once we are using the completion date as a filter to get the top most date of completion for any multiple survey.  

Any Idea why this may happen?

Thanks
Bryan

Comments

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    I have no idea why this would be happening and it very well may be a bug.
    What version of the Survey App are you or the customer running?
    v7.5.3079.512 is the latest version.

    Is this happening on multiple records?
    Did an update to the portal happen on or about when these records were created?

    As much info as you can provide would be great and we can try and repro.

    Thanks
  • Bryan_SchrippeBryan_Schrippe Premier Partner IT Monkey ✭
    Hey Brett.  The customer is currently running v7.5.3079.511.  I did not see any major items relating to this in the release notes for 512, so hopefully there is not anything in there that may cause it.  

    Surveys have been slow to come in thus far, but at the moment this is the only record that has had this behavior.  I figured I would ask the question since I don't want to have a systemic issue in the future.

    No update to the portal has happened either.  We upgraded them to the latest version earlier in the engagement before we installed the survey module.

    We only have one survey at the moment with 6 questions met with list items.  We have went through several iterations of it though and are now at version 8.

    Dashboard metrics for the surveys look correct, although I don't think those are keying off the completed date, but more of a count metric.

    If there is anything else you need let me know.  I'll update this thread as more surveys come in so I can see if there is any more that have this issue.

    Thanks,
    Bryan
  • seth_coussensseth_coussens Product Owner Ninja IT Monkey ✭✭✭✭
    Hey Brian, this is the first I've heard of this issue. I'll take a look at the code and see if there is a reason that this would happen. Especially odd that it would happen on one and not the other...
  • Bryan_SchrippeBryan_Schrippe Premier Partner IT Monkey ✭
    Thanks Seth,  the customer has received a few more surveys, and no issue thus far.  I found it odd as well.  Let me know if you find anything of note!  Much appreciated!
  • Maria_Jose_Cortez_deMaria_Jose_Cortez_de Customer IT Monkey ✭
    Hi all!
    I wonder, is there any update about this topic? I am experiencing the same issue in my Production environment, there is no data into the CompletedDate column. do you have any suggestions about it?
Sign In or Register to comment.