IT Monkey:    
Effective January 30, 2018 this app has been retired by Cireson. Cireson will no longer provide future feature updates, security patches, or support. However, the functionality you know and love has been enhanced and integrated into the new True Control Center.

To get the most of out of your System Center investment and to ensure compatibility with other software applications and systems, we recommend you take advantage of the True Control Center. Take it for a test drive in our online demo lab or request a free 30-day trial.

Unable to Post any announcements

Hi Guys,

Having just upgraded to v.1.2.1608.9 I am currently unable to post any announcements to any of our Device collections. It worked immediately after the install when I tested it but now seems to have stopped working. The error log is about as helpful as a Chocolate Teapot;

08/11/2016 11:33:01 DOMAIN\Admin_User : ------------ Initializing new instance of Cireson Ticker App --------------
08/11/2016 11:33:01 DOMAIN\Admin_User : ------------ Cireson.TickerAdmin version 1.2.1608.9 --------------
08/11/2016 11:33:01 DOMAIN\Admin_User : ------------ Hosted by System Center Configuration Manager version 5.0.8412.1307 --------------
08/11/2016 11:33:01 DOMAIN\Admin_User : ------------ Connected to Site *** --------------
08/11/2016 11:33:01 DOMAIN\Admin_User : Found custom severity 'Information'. Adding to list
08/11/2016 11:33:01 DOMAIN\Admin_User : Found custom severity 'Warning'. Adding to list
08/11/2016 11:33:01 DOMAIN\Admin_User : Found custom severity 'Critical'. Adding to list
08/11/2016 11:33:01 DOMAIN\Admin_User : Found Color Scheme 'Default Color Scheme'. Adding to list
08/11/2016 11:33:01 DOMAIN\Admin_User : Loading color scheme 'Default Color Scheme'.
08/11/2016 11:33:01 DOMAIN\Admin_User : Loading color scheme 'Default Color Scheme'.
08/11/2016 11:33:01 DOMAIN\Admin_User : Loading posted announcements. Expired announcements are excluded
08/11/2016 11:33:06 DOMAIN\Admin_User : Preparing to post announcement.
08/11/2016 11:33:06 DOMAIN\Admin_User : Checking if current user has permissions to initialize client notification for collection '*Device Collection'.
08/11/2016 11:33:06 DOMAIN\Admin_User : Current user has permission to initiate client notification, proceeding.
08/11/2016 11:33:06 DOMAIN\Admin_User : Initiating Client Notification actiontype 8 for collection '*Device_Collection'
08/11/2016 11:33:06 DOMAIN\Admin_User : Client Notification method returned operationID 16777602
08/11/2016 11:33:06 DOMAIN\Admin_User : Getting TaskID for currently processed Client Notification.
08/11/2016 11:33:07 DOMAIN\Admin_User : Returned TaskID {3e639118-953a-49d0-968a-06c2968498fd}
08/11/2016 11:33:07 DOMAIN\Admin_User : Checking if Inventory Class 'Cireson_Ticker' exists.
08/11/2016 11:33:07 DOMAIN\Admin_User : Inventory Class 'Cireson_Ticker' exist. Setting Announcement details.
08/11/2016 11:33:07 DOMAIN\Admin_User : Altering inventory configuration to hold the Announcement.
08/11/2016 11:33:07 DOMAIN\Admin_User : Mof data retrieved. 1102 characters imported
08/11/2016 11:33:07 DOMAIN\Admin_User : Connecting to namespace '\\SERVER\root\sms\site_***'.
08/11/2016 11:33:07 DOMAIN\Admin_User : Successfully connected to namespace '\\SERVER\root\sms\site_***'.
08/11/2016 11:33:07 DOMAIN\Admin_User : Importing Mof data into ConfigMgr.
08/11/2016 11:33:07 DOMAIN\Admin_User : Error: Unable to save inventory configuration. (No inner exception)
08/11/2016 11:33:07 DOMAIN\Admin_User : Error message:


Yes, the Error message is blank.

The messages are well within the character limit. There are no Special characters.

Your help would be very much appreciated.

Answers

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    My first suggestion is to upgrade.
    I know there were some fixes in later versions.
    We are currently at v7.2012.0 (New version formatting)

    Try that and let us know how you go.

    Hope this answers your quesiton
  • Amesy86Amesy86 Member IT Monkey ✭
    How do I get version 7? I requested it from the front page and just got sent version 1.2.1608.9 again
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Not sure where Brett got that version. You are current if you are running 1.2.1608.9. If you want to post the admin log as well as the SMSProv.log (from the same timeframe as the Ticker post attempt), then we can look at the issue for you.

    If it worked previously, and not now, that doesn't make much sense.
  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    edited November 2016
    Sorry @Amesy86
    The download site had it's version number updated on the site but the version you are running 1.2.1608.9 is the most current one.

    The error that you are getting for "Unable to save inventory configuration" seems to be related to rights or the inability to save the policy.
    Are you running this from the Primary server?
    Do you have a CAS?

    Attach the admin log as @wally_mead suggests and one of us can take a look
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Yes, I see that somehow the versions got updated on the download site to confuse people. Not sure how that happened, however you are running the most current version.
  • Amesy86Amesy86 Member IT Monkey ✭
    edited November 2016

    You'll have to excuse me but which Admin Log are you looking for? Was that not what I posted above?

    To answer your other questions, We do not use a CAS and the Console we are running it from is actually separate of the Primary Server. The Permissions thing could be the trouble as I can still post on this but the people who usually post the Announcement cannot and they have very limited access to SCCM. This worked before the upgrade so perhaps some of the Console access requirements have changed?

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    An administrative log is created to track use of the Configuration Manager Ticker Admin App. This log is created in the Configuration Manager Console’s installation directory. In a default installation, that would be created in the %ProgramFiles(x86)\Microsoft Configuration Manager\AdminConsole\AdminUILog\Cireson folder. In this log, Cireson TickerAdmin.log, you will see entries to record that the logged on user has rights to initiate a Client Notification cycle, the collection the announcement is being created for, the announcement ID and message, and so on.

    For the client component, there are a few logs of interest as well. Starting with the actual log file for the Configuration Manager Ticker Client App. This log is created in the logged on user’s profile path at %UserProfile%\AppData\Local\Cireson\ConfigMgr Apps\Ticker app. The log file name is “Cireson TickerApp.log”. In this log, as shown in the following snip, you will see the announcement IDs, whether they are processed already, the announcement details, when the ticker banner is being displayed, when it is dismissed, and so on.

    The Cireson Configuration Manager Ticker Admin App can be used by any Configuration Manager administrative user who has access to the Configuration Manager Console, and has at least the following specific permissions assigned to the security role:

    • Collection – Deploy Client Settings
    • Inventory Reports – Modify

    For example, if you were to copy the Read-only Analyst role, and add the two permissions above to the new custom role, any administrative user with the custom role assigned to it should be able to create announcements for any device collections that the admin user has access to.

    I hope this answers your question.

  • Amesy86Amesy86 Member IT Monkey ✭

    Thanks Brett. This is what I posted in my first post.

    I have attached the error log from yesterday which shows the User trying (Unsuccessfully), followed by me trying (successfully).

    I can confirm the user has the permissions mentioned in the above post.

    There is no mention of the Incident on the target PC's log, so I have not included it. I have tried to get the user to do this on the Primary Server as well and got the same results. I am waiting for them to try with Elevated rights on the server and will let you if that works or not, but I doubt it will as I have the same rights as the user on the other server where the Console is installed and I have no issues there. This is why I queried if the Required SCCM Access permissions may have changed between versions.

  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    To answer the question, no, that I can recall, the required rights to use the Ticker app have not changed between the original release and the v1.2 version. I'll ask the developer of the app take a look to verify, but I can't think of any permission changes. If the previous release worked, then I would think that it should still work with v1.2. Stay tuned.

    And as to the admin log, yes, you pasted in the contents but we usually ask for the log anyway, just in the even that there are more entries in the log that were not included in the post, or things got chopped off/reformatted during posting. That's why. But if yours is as posted then fine. We'd still want the smsprov.log from the site server AT the time of the test as well so we can validate what it is trying to do.
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    I was just searching email on permissions, and these are the final ones from dev (the last that I saw). Slightly larger than what Brett posted above, but what dev said is required:

    "Client Agent Settings": Read

    "Collection": Read, Deploy Client Settings.

    "Inventory Reports": Read, Modify

    "Site": Read

    "Status Messages": Read
  • Amesy86Amesy86 Member IT Monkey ✭
    edited December 2016

    Hi Guys, Sorry for not getting back to you sooner. Please find attached the "SMSProv.log" and "Cireson TickerAdmin.log" files at the time of posting. I have had to redact the Server name, Username, and Site Code (InfoSec wouldn't let me post it otherwise) I have not deleted or altered anything else. Please let me know if you need anything further.

    I can confirm that the required access rights are assigned. I get the same error using my "Full_Administrator" account so I don't think it's a permissions thing. I don't seem to get the error on another Collection this just has my own PC in it), but I have deleted and re-created the Collections (there are more than one) we are getting the error with and this hasn't resolved the issue.

    Thanks again for your help.

  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Thanks, I'll ask my dev to take a look and see if he can notice anything in the logs that would indicate an issue. We'll get back to you early next week.
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Hi Amesy,

    Dev looked at the logs, and unfortunately, they don't line up properly :-( The SMSProv.log had already rolled over by the time you saved it, so it did not have the data related to the Ticker attempt in it. It was only missing by a few seconds. But that log file does roll over really quickly by default, as it logs all use of the Configuration Manager Console.

    So we'll need you to try again, and potentially include the backup SMSProv.log if it does roll over again.

    Sorry about that,

    Wally
This discussion has been closed.