Can't view AM Subnets?

Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
edited November 2016 in Asset Management
Has anyone experienced an issue wherein the Subnet portion of Asset Management can't be viewed despite altering the permissions with the Cireson tool for Incident Resolvers, Advanced Operators, etc?

As expected, users added to the SCSM admins role have no problem creating/editing/viewing these objects but everyone else (in those altered roles) can't see subnets. They can however interact with any other AM object. This behavior is reproducible in the console and portal.

Best Answer

Answers

  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    I have seen this. I believe @Dennis_de_Jager had this issue. I cannot recall how it was fixed. Dennis, can you remember?
  • Dennis_de_JagerDennis_de_Jager Customer IT Monkey ✭
     @Geoff_Ross , I think this was automatically solved by running the newest versions...  So we reproduced the issue in the test environment on version 5 and after upgrading Cireson portal and asset management to the versions offered in the beginning of October. 

    Which versions are you running @Adam_Dzyacky ?

  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    I also submitted a Cireson support ticket on this and it was immediately confirmed a bug. But you're giving me some confidence here @Dennis_de_Jager

    Asset Management v7.5.2012.148 (latest at time of this writing)
    Portal v5.0.8.1
  • Dennis_de_JagerDennis_de_Jager Customer IT Monkey ✭
    My Test environment runs Portal 6.0.3 and there this doesn't happen... in our live environment I still have this issue. Upgrading is a bit of a hassle, but we're getting there.
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    What about console?
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Adam, did you ever get anywhere with this? Have you had a chance to upgrade to latest version of AM?
  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    OK, thanks for confirming for the purposes of this thread.
  • Dennis_DanekDennis_Danek Partner IT Monkey ✭
    Is this still an unfixed bug?
    Today, i struggled with this issue too (Asset Management V...151, newest one)
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    Unfortunately yes.
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    edited October 2017
    Can't believe I've overlooked this, but I have a workaround - if you create a SCSM Group that contains all Cireson Asset Management Subnets (e.g. Dynamic Membership where IP Mask is not empty or just Subnet with no criteria). This group can now be assigned to a Security Role enabling said role to create and edit members of this class.

    Currently having an issue deleting right now, but should be able to curb this with further permissions.
Sign In or Register to comment.