Home Service Manager

Have you ever tried saving a WI template and encountered a MP mapping error msg?

Mark_WahlertMark_Wahlert Customer Advanced IT Monkey ✭✭✭
So I bought some fish and chips, then tried editing a template and it kept crashing with some MP relationship error. Our  workaround was to duplicate the RO and template and then edit the activities. That also required: delete old RO/template and restitch the old with the new in the DB.

One day after lunch, the solution became clear.... Remove all prompt mapping for all activities in the RO. Then edit the template and it should let you save. Then remap the prompts. 

Sadly prior to realising this we had duplicated about a dozen or more ROs which caused our reporting guru a headache when all submitted SRs using these replaced ROs became orphans in the DB.

Back to lunch.


  • Options
    TysonTyson Member IT Monkey ✭

    We have the same issue on our Advanced ROs. Depending on the change we are trying to make to the Advanced RO we have to redo all of the multi-mappings. This is not an exciting thing to do.

    I would be interested to know if there are any plans to fix this or if there are better work arounds. When you have an offering that has 16 activities all multi-mapped out fixing them each time is a bit of pain.


Sign In or Register to comment.