Home Advanced Request Offering

Object Reference Error after adding Runbook Activity

Hello Everyone,

I had a request built out via the Advanced Request Offering and everything was working correctly.  I recently made some changes to the request by adding a RA activity.  I've also hid a few items on the self service portal using a custom css file.  I went back and made some changes to the RA activity and when i attempted to open the multiple mapping interface to add a new field I received this below error.  

If i have to I'll rebuild the request but I'd still like to have some idea what happened here.  

Any assistance is appreciated. 

Date: 1/9/2017 2:41:34 PM
Application: System Center Service Manager
Application Version: 7.5.7487.0
Severity: Error
Message: Object reference not set to an instance of an object.

System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.EnterpriseManagement.UI.SdkDataAccess.ConsoleTaskHandler.DoTask(IList`1 navigationNodes, NavigationModelNodeTask task, List`1 parameterList)
   at Microsoft.EnterpriseManagement.UI.SdkDataAccess.ConsoleTaskHandler.DoTask(IList`1 navigationNodes, NavigationModelNodeTask task)
   at Microsoft.EnterpriseManagement.ServiceManager.UI.Console.ConsoleJobExceptionHandler.ExecuteJob(IComponent component, EventHandler`1 job, Object sender, ConsoleJobEventArgs args)

Best Answers


  • Billy_WilsonBilly_Wilson Member Ninja IT Monkey ✭✭✭✭
    FYI - I experienced the same issue and removing the data from the <MulitpleMapping> section of the Management Pack xml fixed it, however I had to remap everything. I imagine I could have figured a way to simply remove the changes but I didn't really have the time.
  • Brian_WinterBrian_Winter Customer Advanced IT Monkey ✭✭✭
    Same experience here.  I swapped out an activity and my ARO blew up as soon as I tried to access Multiple-Mapping.  I had to export the MP, edit the XML, find the MultipleMapping node and remove it.  Once gone and the MP reloaded, I was able to edit the ARO.

    Thanks @Jarrett_Faulk for this post!
Sign In or Register to comment.