IT Monkey:    
Effective January 30, 2018 this app has been retired by Cireson. Cireson will no longer provide future feature updates, security patches, or support. However, the functionality you know and love has been enhanced and integrated into the new True Control Center.

To get the most of out of your System Center investment and to ensure compatibility with other software applications and systems, we recommend you take advantage of the True Control Center. Take it for a test drive in our online demo lab or request a free 30-day trial.

Community edition portal license key

Will you provided a key to install the community edition?

Answers

  • F_ChristiansenF_Christiansen Cireson Dev Advanced IT Monkey ✭✭✭
    Hi Terrence,

    You should just leave it blank.
    Then if you want a fully functional version, you will get a license key that unlocks the features.

    Best regards
    Flemming Appelon Christiansen
  • Terrence_DavenportTerrence_Davenport Customer IT Monkey ✭

    Leaving blank does not work.  It is requiring a key

  • F_ChristiansenF_Christiansen Cireson Dev Advanced IT Monkey ✭✭✭
    Are you using the installer to install Portal for Configuration Manager?
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Hi Terrence

    Do you have any screenshots? Just tested and confirmed I could proceed with a blank license key:






  • TomGibsonTomGibson Member IT Monkey ✭
    How do we get past this error?
    Error processing powershell: AuthorizationManager check failed

    I have set my powershell execution policy to unrestricted. I have run the installer as administrator. Same error. The account I am logged into has administrator access on the web server I am on as well as the database server. The same account is used for the application pool identity
    ps-remoting is enabled on the siteserver/db server.

    And... most of the time the install status will say Success or there were Some Warnings, even though the above error occurred.

    Would you be able to provide the steps necessary for the manual installation?

    Thanks!
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Hi Tom

    Are you running the installer locally on VM or from UNC path? 

    Make to run locally and before you unzip right click and go to properties, unblock the zip file then unzip.

    let me know if that helps or if you still have the same error.

    cheers
    joe
  • TomGibsonTomGibson Member IT Monkey ✭
    initially I was running it from another server. I then copied the unzipped files over to the server that will host the website. And finally I have tried unblocking the exe. I did not unblock the zip and then unzip. I will try that next.
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    And here I thought this was just a "me" issue. What Joe described was my exact line of troubleshooting that resolved this very issue @TomGibson .
  • TomGibsonTomGibson Member IT Monkey ✭
    edited June 2017
    I almost made it!. I unblocked the zip first - thanks for that suggestion - and made it much further.  
    Here is my current installation error:

    6/16/2017 1:42:36 AM Starting to deploy the website...

    6/16/2017 1:42:36 AM Error processing powershell: The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: ERROR: The system was unable to find the specified registry key or value.

       at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)

       at System.Management.Automation.PipelineOps.InvokePipeline(Object input, Boolean ignoreInput, CommandParameterInternal[][] pipeElements, CommandBaseAst[] pipeElementAsts, CommandRedirection[][] commandRedirections, FunctionContext funcContext)

       at System.Management.Automation.Interpreter.ActionCallInstruction`6.Run(InterpretedFrame frame)

       at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)

    My other problem appears to be that I am installing this on  a server with IIS, but not SQL so powershell's invoke-sqlcmd does not exist. Guess I need to load the SQL tools on this server too.

    Any progress on the manual installation instructions??

    Thank you

  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Hi Tom 

    Will PM you with the guide.

    Cheers
    Joe
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Hi Tom,

    I believe that you have the installation guide now (from our discussion at the user group meeting last week). Is all good now? If not, start a new thread so it doesn't get lost in this one :-)

    Thanks,

    Wally
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    edited June 2017
    To onloookers of this thread who get the next error message @TomGibson states above:

    The registry key attempting to be queried here (I'm fairly certain) is the MSDeploy reg key. For the unaware, MSDeploy/WebDeploy is a Microsoft plugin for IIS that further extends administrative capabilities of IIS. You can grab it here - https://www.iis.net/downloads/microsoft/web-deploy

    I've submitted a feature request on making this check/error a bit more enhanced here.

  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Hi Adam,

    I am not familiar with MSDeploy. To my knowledge, I've never downloaded it or deployed it. And I can use the Installer to install the CMP successfully. If you want to provide more details on what you think is really missing, I can verify my environment for it.

    Wally
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    edited June 2017
    Sure thing, so here's how I arrived at this.

    1. Installed and had the permissions issue originally cited by Tom. Unblocked the whole zip, extracted, ran the installer.
    2. Installer now throws the other aforementioned error and an inability to query a registry key.

    Walked through the Installer directory for the Cireson ConfigMgr Portal and came across "InstallCMPortal.ps1" and came across the InstallConfigMgrPortalWebsite() function. Since I had tried multiple times to install the website, and I believed at the time I had all the pre-requesites. I ran this function line by line.
    • Able to leverage IIS cmd-lets. Check.
    • Able to execute native PowerShell (remove-item, etc.) Check
    • Able to query the IIS:\ PS drive. Check
    • No mention of registry keys anywhere here despite my error. Check
    Line 589 of InstallCMPortal.ps1 has a - "Invoke-Expression  "website\ConfigMgrPortal.UI.deploy.cmd /Y" | Write-Output"

    Navigated over to this path to discover a command line series of events. That file contains the following:
    @rem Please Make sure you have Web Deploy install in your machine. 
    @rem Alternatively, you can explicit set the MsDeployPath to the location it is on your machine
    @rem set MSDeployPath="C:\Program Files (x86)\IIS\Microsoft Web Deploy V3\"
    @rem ---------------------------------------------------------------------------------
                          
    @rem ---------------------------------------------------------------------------------
    @rem if user does not set MsDeployPath environment variable, we will try to retrieve it from registry.
    @rem ---------------------------------------------------------------------------------
    if "%MSDeployPath%" == "" (
    for /F "usebackq tokens=1,2,*" %%h  in (`reg query "HKLM\SOFTWARE\Microsoft\IIS Extensions\MSDeploy" /s  ^| findstr -i "InstallPath"`) do (
    if /I "%%h" == "InstallPath" ( 
    if /I "%%i" == "REG_SZ" ( 
    if not "%%j" == "" ( 
    if "%%~dpj" == "%%j" ( 
    set MSDeployPath=%%j
    ))))))
    

    Now that's a registry key! So at this superficial glance, I went to that directory and sure enough I was missing the path. So I went to go download MSDeploy. Re-ran the CMP installer and was up and running without errors.

    As I was preparing my response here and re-tracing my steps I accidently walked into the "MSI" directory of the installer. Which oddly enough contains the MSI for WebDeploy. I'm certainly comfortable leaving this to a "unknown customer environment variable" but the references I see to calling the invocation of the MSI reference it as an *.exe instead of its *.msi. Again, could just as easily be overlooking some portion of the installer code but this was my experience and line of troubleshooting that got me working.
  • seth_coussensseth_coussens Product Owner Ninja IT Monkey ✭✭✭✭
    @joivan_hedrick
    please see the above
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    OK, I just did a clean install of the Community Edition of the CMP. I do see that Registry key that you mention now. If it is part of the Installer, then that makes sense, as I've never even heard of this, let alone installed it manually before.
This discussion has been closed.