SCSM 2016 Cireson itnetx advanced Send Email error

AutoFitAutoFit Member IT Monkey ✭

Hello all,

I have been battling this error for few days now, and I am still not seeing that light at the end of the tunnel, so any help is greatly appreciated.

Service manager 2016 updated with the latest and greatest and it's not live yet because of this issue, because it's a primary requirement. 

I am able to use the send email feature from within an incident form, but not from within a service request form or change request form and I get this error message:

Date: 6/17/2017 6:01:15 PM
Application: System Center Service Manager
Application Version: 7.5.7487.0
Severity: Error
Message: Error

System.ArgumentException: propertyName
   at Microsoft.EnterpriseManagement.UI.SdkDataAccess.DataAdapters.EnterpriseManagementObjectProjectionDataType.GetPropertyValue(Object source, String propertyName)
   at Microsoft.EnterpriseManagement.UI.SdkDataAccess.DataAdapters.BindableCachedDataItem`1.get_Item(String propertyName)
   at itnetx.consolemail.assembly.Classes.ConsoleMailWizardData..ctor(WorkItemTypeEnum type, IDataItem& dataitemIncident)
   at itnetx.consolemail.assembly.Classes.ConsoleMailTaskHandler.ExecuteCommand(IList`1 nodes, NavigationModelNodeTask task, ICollection`1 parameters)

As stated previously; Any help is greatly appreciated.

Thanks in advanced.

Answers

  • Konstantin_Slavin-BoKonstantin_Slavin-Bo Customer Ninja IT Monkey ✭✭✭✭
    I know that the SDK have changed some essential calls in SCSM 2016, and the error message points to that the connection to the SDK isn't created correctly. Are you sure, that you are using the 2016 version of the app (sorry for the question, but sometimes its the simplest things)? Or maybe Cireson "forgot" to update the SR / CR part of the code (the implementation is separate from IR)?
  • AutoFitAutoFit Member IT Monkey ✭
    oh I am 100% sure of that, because I imported the MP myself :)
  • Konstantin_Slavin-BoKonstantin_Slavin-Bo Customer Ninja IT Monkey ✭✭✭✭
    Then I'm unfortunately out of ideas. Maybe someone from Cireson can confirm, that the Send Mail solution is actually ported to SCSM 2016 for SRs and CRs? I know that CTGlobal has developed a solution for Send Mail for SRs in SCSM 2016 (link), and I can see, that there's some significant code changes from SCSM 2012 R2.
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    AutoFit said:

    Hello all,

    I have been battling this error for few days now, and I am still not seeing that light at the end of the tunnel, so any help is greatly appreciated.

    Service manager 2016 updated with the latest and greatest and it's not live yet because of this issue, because it's a primary requirement. 

    I am able to use the send email feature from within an incident form, but not from within a service request form or change request form and I get this error message:

    Date: 6/17/2017 6:01:15 PM
    Application: System Center Service Manager
    Application Version: 7.5.7487.0
    Severity: Error
    Message: Error

    System.ArgumentException: propertyName
       at Microsoft.EnterpriseManagement.UI.SdkDataAccess.DataAdapters.EnterpriseManagementObjectProjectionDataType.GetPropertyValue(Object source, String propertyName)
       at Microsoft.EnterpriseManagement.UI.SdkDataAccess.DataAdapters.BindableCachedDataItem`1.get_Item(String propertyName)
       at itnetx.consolemail.assembly.Classes.ConsoleMailWizardData..ctor(WorkItemTypeEnum type, IDataItem& dataitemIncident)
       at itnetx.consolemail.assembly.Classes.ConsoleMailTaskHandler.ExecuteCommand(IList`1 nodes, NavigationModelNodeTask task, ICollection`1 parameters)

    As stated previously; Any help is greatly appreciated.

    Thanks in advanced.


    Hello @AutoFit


    I'm currently investigating this issue. Would you mind opening a support ticket with us as well - https://support.cireson.com/ServiceCatalog/RequestOffering/5a0d0595-9096-6cfe-911c-9a03cb2817f9,bebefee7-84c5-5dc8-7fed-adc7345da87e

    Thank you,

    Merle
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    As far as I know this is a bug that I raised for the previous release of the MP.
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    As far as I know this is a bug that I raised for the previous release of the MP.
    What was the ticket# I can't seem to find one in the system
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    IR62050 related to PR62052
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    Thank you.

    @AutoFit please submit a ticket for your issue an I can ad that to the PR
This discussion has been closed.