Home Service Manager

integer is not being passed to Runbook activity

Anthony_BrzozowskiAnthony_Brzozowski Customer IT Monkey ✭
We have a service offering for HR to create new users . The service request form asks for 12 inputs including first name , last name , department , city ,state , etc. the first 10 inputs are mapped to Text 1- 10 but the last 2 are mapped to integer1 and 2. the problem is that those 2 inputs are not being passed to the runbook activity those fields end up blank when the AD account is created. How do I map these integers? It looks like when the ticket is created the 2 integers are placed in the service request form under the extension tab as srExt_text11 and 12.

Best Answers


  • Options
    Anthony_BrzozowskiAnthony_Brzozowski Customer IT Monkey ✭
    Hi Anthony,

    I believe you want to remap those in the RB Activity from Integer1 & 2 to Longtext1 & 2.  Give that a go.

    Mike ,

    thanks for your response. I tried changing it but it still didn't pass the input to the runbook.
  • Options
    Anthony_BrzozowskiAnthony_Brzozowski Customer IT Monkey ✭
    You would need to change the Runbook Activity Template in the Service Request Template to point the Integer1 and Integer2 to point to the extensions srExt_text11 and 12 respectively. 

    If the Integers are actually looking for integers, then you won't be able to fill those fieldds with anything besides numbers (not ideal for phone number, as they can use spaces, dashes or brackets and Department would need to be a text field)

    Start by opening the Template in the section Library>Templates and then loading the Runbook Activity. You should be able to find what you need to change there

    thanks for your response. I tried to change the mapping to Text 11 and 12 but I don't have that option

  • Options
    Anthony_BrzozowskiAnthony_Brzozowski Customer IT Monkey ✭
    Thanks for your help guys I finally figured it out.
Sign In or Register to comment.