Sevice request when attachment included you don't get chnage status options

James_PalmerJames_Palmer Customer IT Monkey ✭
When we create a service request and attach a file, be it a word doc, excel spreadsheet, screenshot, when we go to close the case, i.e. change status, we only get "on hold" and "cancelled",  instead of "completed".
If we have a service request with no attachment then we get "completed" when we go to change status.

Ideas please .........

Answers

  • Justin_WorkmanJustin_Workman Cireson Support Ninja IT Monkey ✭✭✭✭
    @James_Palmer - I think the file attachment may just be a coincidence.  The Status that an SR can be put into next is determined by its activities.  If it doesn't have any activities it can only go from Submitted to Completed.  If it has activities, it will typically go from In Progress to Completed once the Activities all complete.
  • James_PalmerJames_Palmer Customer IT Monkey ✭
    Hi Justin,
    Ok, fair enough, i'll look out for this, but how come some have activities and others don't when i'm using onlt one template?
    cheers
    James

  • Justin_WorkmanJustin_Workman Cireson Support Ninja IT Monkey ✭✭✭✭
    @James_Palmer - I can't explain why some SRs might have activities while others do not if you're using the same template.  My guess would be that the SRs are coming from different sources and in fact are using different templates OR there's a workflow(or some kind of automation) adding activities after the fact.
  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭
    @James_Palmer - I can't explain why some SRs might have activities while others do not if you're using the same template.  My guess would be that the SRs are coming from different sources and in fact are using different templates OR there's a workflow(or some kind of automation) adding activities after the fact.

    ...or the out of box Exchange Connector is configured to use a Template that contains activities on Work Item Update. It's a classic gotcha worth highlighting.
  • James_PalmerJames_Palmer Customer IT Monkey ✭
    edited April 10
    @Adam_Dzyacky you're right - just checked got the default templates not our templates.......

Sign In or Register to comment.