Custom Form for a Work Item class is not shown if the corresponding Cireson Preview Form is enabled

merlenette_jonesmerlenette_jones Advanced IT Monkey ✭✭✭
edited June 2016 in Preview Panes
This is caused by a console bug. There are 2 types of forms, forms used by classes when you edit that class
and forms marked as "overview" forms that are used in the preview pane.

When you edit a class, the console gets all forms for that class and alpha sorts their Guids. If the first form found is
an overview form, it is not correctly skipped and the default (uncustomised) OOB form is loaded instead.

To workaround this problem, the internal Id of the preview pane form must be changed until the customised class form is selected.

We will use Manual Activity as an example, please change MPs accordindingly for your problem class.

First, delete this Management Pack using the SCSM console via Administration\Management Packs:

Cireson Preview Pane - Enable Manual Activity

Extract the contents of the supplied Cireson zip to a temp folder.

Import PreviewForms.EnableManualActivity.mp from this ZIP. Restart the console and try again.

This might have solved your issue. If not:

1. Open the Management Pack XML in an XML Editor such as Visual Studio or Notepad.

2. Find the line starting with "<Form ID=" and change the form Id to something else.

   For example, change "AAAAAAMA.Form" to "SomeOtherFormID". Any unique Id can be used in an attempt to get the Guids to sort correctly.

3. Increase the version of the Management Pack in the <Identity> section by at least one. 

   For example, change:

     <Version>7.5.20000.3</Version>

   to:

     <Version>7.5.20000.4</Version>

4. Save your changes and reseal the Management Pack using Reseal.bat.

5. Import the new version and restart the console.

6. Re-test the issue.

7. Repeat, changing the form id each time, until your custom form is used.

Comments

  • TysonTyson IT Monkey ✭
    Merl- 

    We have been trying to make this work with our custom CR forms and have been running into some errors:

    The management pack import failed. 
    Errors (2):
    (1) The Target attribute value is not valid. Element PreviewForms.EnableChangeRequest.Category references a Target element that cannot be found.

    (2) The Target attribute value is not valid. Element AAAAAA.Category references a Target element that cannot be found.

    The second error was fairly easy to track down, however we cannot seem to pinpoint the issue on the first issue. 

    Any help?

    Thank you
  • merlenette_jonesmerlenette_jones Advanced IT Monkey ✭✭✭
    Tyson said:
    Merl- 

    We have been trying to make this work with our custom CR forms and have been running into some errors:

    The management pack import failed. 
    Errors (2):
    (1) The Target attribute value is not valid. Element PreviewForms.EnableChangeRequest.Category references a Target element that cannot be found.

    (2) The Target attribute value is not valid. Element AAAAAA.Category references a Target element that cannot be found.

    The second error was fairly easy to track down, however we cannot seem to pinpoint the issue on the first issue. 

    Any help?

    Thank you
    Hello Tyson,

    Just want to cover the basis fist. So forgive me if I'm being redundant. 

    Did you seal the MO before importing it? You most likely did. 

    Are you able to post your custom XML so I can see what changes you made?
  • TysonTyson IT Monkey ✭
    Merl-

    Thanks for the prompt response. We sure have been sealing the MP. 

    Here is the XML:

    <ManagementPack ContentReadable="true" SchemaVersion="2.0" OriginalSchemaVersion="1.1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
      <Manifest>
        <Identity>
          <ID>PreviewForms.EnableChangeRequest</ID>
          <Version>7.5.20000.4</Version>
        </Identity>
        <Name>PreviewForms.EnableChangeRequest</Name>
        <References>
          <Reference Alias="Console">
            <ID>Microsoft.EnterpriseManagement.ServiceManager.UI.Console</ID>
            <Version>7.5.0.0</Version>
            <PublicKeyToken>31bf3856ad364e35</PublicKeyToken>
          </Reference>
          <Reference Alias="PF">
            <ID>PreviewForms</ID>
            <Version>7.5.0.0</Version>
            <PublicKeyToken>98ba2176e2a9efbc</PublicKeyToken>
          </Reference>
        </References>
      </Manifest>
      <Categories>
        <Category ID="PreviewForms.EnableChangeRequest.Category" Value="Console!Microsoft.EnterpriseManagement.ServiceManager.ManagementPack">
          <ManagementPackName>PreviewForms.EnableChangeRequest</ManagementPackName>
          <ManagementPackVersion>1.0.0.0</ManagementPackVersion>
          <ManagementPackPublicKeyToken>98ba2176e2a9efbc</ManagementPackPublicKeyToken>
        </Category>
        <Category ID="AAAAAA.Category" Target="AAAAAB.Form" Value="Console!Microsoft.EnterpriseManagement.ServiceManager.UI.Console.OverviewForm" />
      </Categories>
      <Presentation>
        <Forms>
          <Form ID="AAAAAB.Form" Accessibility="Public" Target="PF!TypeProjection.ChangeRequest" Assembly="PF!PreviewForms.dll" TypeName="PreviewForms.ChangeRequestPreviewForm">
            <Category>Form</Category>
          </Form>
        </Forms>
      </Presentation>
      <LanguagePacks>
        <LanguagePack ID="ENU" IsDefault="true">
          <DisplayStrings>
            <DisplayString ElementID="PreviewForms.EnableChangeRequest">
              <Name>Cireson Preview Pane - Enable Change Request</Name>
              <Description>Enables the Cireson Change Request Preview Pane</Description>
            </DisplayString>
          </DisplayStrings>
        </LanguagePack>
      </LanguagePacks>
    </ManagementPack>

    Thank you for the help

  • merlenette_jonesmerlenette_jones Advanced IT Monkey ✭✭✭
    Thank you for posting that. Give me some time to debug this and I'll get back to you soon.

    Merle
  • merlenette_jonesmerlenette_jones Advanced IT Monkey ✭✭✭
    Hello Tyson,

    A couple of things. 

    Looking at the xml I seee a discrepency in the Public Key token

     <Reference Alias="Console">
            <ID>Microsoft.EnterpriseManagement.ServiceManager.UI.Console</ID>
            <Version>7.5.0.0</Version>
            <PublicKeyToken>31bf3856ad364e35</PublicKeyToken>
          </Reference>

    In the rest of the file you have this:

    <Category ID="PreviewForms.EnableChangeRequest.Category" Value="Console!Microsoft.EnterpriseManagement.ServiceManager.ManagementPack">
          <ManagementPackName>PreviewForms.EnableChangeRequest</ManagementPackName>
          <ManagementPackVersion>1.0.0.0</ManagementPackVersion>
          <ManagementPackPublicKeyToken>98ba2176e2a9efbc</ManagementPackPublicKeyToken>
        </Category>

    In the first reference that public key token is from the example file I gave you. 

    I think changing that might work. 

    Let me know,

    Merle
  • TysonTyson IT Monkey ✭
    Merle- (Sorry for spelling it wrong before!)

    Negative, we get the following:

    The management pack import failed. 
    Errors (1):
    Could not load management pack [ID=Microsoft.EnterpriseManagement.ServiceManager.UI.Console, KeyToken=98ba2176e2a9efbc, Version=7.5.0.0]. The management pack was not found in the store.
    : An error occurred while loading management pack 13ceb69c-0fbf-2b6b-1561-2a8a2141556d from the database

    Which is normally a pretty easy fix, but not this time.
  • merlenette_jonesmerlenette_jones Advanced IT Monkey ✭✭✭
    No worries on the name man. My full Name is Merlenette. HAHA! 

    Give me some time to research this and I'll get back to you shortly with a solution 

    Merle
  • TysonTyson IT Monkey ✭
    Merle-

    I appreciate your time and effort!

    Thank you,

    Tyson
  • merlenette_jonesmerlenette_jones Advanced IT Monkey ✭✭✭
    Tyson do you have an email I can send the new MP two? I think I got the issue corrected

  • merlenette_jonesmerlenette_jones Advanced IT Monkey ✭✭✭
    Actually You can download the new XML file here - https://cireson.box.com/s/jkem38aq99ywkz5v8qk8ajzix3dmcon7

    Seal this up and it should work. I did comment out the public key token. Perhaps it didn't like this?

  • TysonTyson IT Monkey ✭
    Merle-

    Still no go. =(

    I am going to uninstall the entire Preview Pane MP and all the enablers and start fresh and see if that helps at all.

    The management pack import failed. 
    Errors (1):
    The Target attribute value is not valid. Element PreviewForms.EnableChangeRequest.Category references a Target element that cannot be found.

    Thanks again for all the time and effort!
Sign In or Register to comment.