Home Analyst Portal

User Settings page does not show the email address of the user

Ingrid_GlatzIngrid_Glatz Customer Adept IT Monkey ✭✭

After upgrading to portal version 8.9.5, I had planned to modify the UserProfile.js to add some additional fields to be displayed in the user settings page. I've seen today that the page doesn't show the email address of the logged on user and I'm almost sure that this was visible before the upgrade.

We have a multi-forest environment. My admin account which resides in the same forest like the portal server shows the email address on the user settings page. My regular account in a different forest has an empty field. The email field in AD object is definitely populated. The info is also displayed in the user details page when clicking the blue info button and select "view more details".

I haven't edited the UserProfile.js so far, it's still the original version. Am I missing permissions for the application pool identity or any other configuration?

Ingrid

Best Answer

Answers

  • Ingrid_GlatzIngrid_Glatz Customer Adept IT Monkey ✭✭

    Hi Steve,

    thanks for the answer. I'll open up a support ticket and send all information with it.

    Ingrid

  • James_JohnsonJames_Johnson Customer Adept IT Monkey ✭✭
    Hi Ingrid,

    We are running 8.9.5 as well and still see email address in the UserProfile page. No customization at all to the UserProfile.js

  • Ingrid_GlatzIngrid_Glatz Customer Adept IT Monkey ✭✭

    Hi James,

    it's with support now.

    I see email addresses of users that are in the same domain like the portal servers. Email addresses from users from other domains/forests are not displayed.

    Do you have a single domain/forest environment or more than one forest?

  • James_JohnsonJames_Johnson Customer Adept IT Monkey ✭✭
    Just a single domain
Sign In or Register to comment.