We're excited to introduce you to 14 new Remote Management apps as part of the existing Service Management Stream!

These modern, web-based, user and device management tools for Analysts help further maximize productivity, deliver faster problem resolution and increase end user satisfaction.

Check out our on-demand webinar to find out how these new apps fit into your existing Team or Service Management Foundation license, see a technical overview demo, and more.View the installation & setup webinar to learn how to get started with Remote Management.

Remote Management integration with analyst portal - iframe http 500 error

Hi,
I configured Remote Management app on a test server (all-in: SQL server, SCSM, Analyst Portal). I configured a random port for RM (:90) and I set the link to the RM in the portal Integration Settings. Now, on localhost it works with no issues. When accesing from intranet, it works if I access the Remote Management web service (with all functionalities) but as soon as I access it from portal (iframe) I'm getting an http 500 error which also blocks the session. I restart the browser and stand alone RM works, but iframe again doesn't work. Anyone knows what setting should I do in order to configure correctly?
To resume:
1. I have analyst portal on port 80: http://cdtciresontest
2.On the same server I have RM on port 90: http://cdtciresontest:90
3. I configured the integration settings on analyst portal to http://cdtciresontest:90
4. The RM works correctly when in stand alone (accessing the link from browser http://cdtciresontest:90) but it doesn't work from portal (iframe - error http 500, which blocks also the stand alone until restart)
5. On localhost it works with no issues
Thanks a lot for your help...

Comments

  • Tom_HendricksTom_Hendricks Customer Super IT Monkey ✭✭✭✭✭
    I am seeing similar behavior, if not exactly the same.  If I set the portal integration to https://FQDNofMyServer:port/ then it works.  If I set the portal integration to https://wellKnownDNSAliasOfSameServer:port/ then it connects but gives a 500 error that I cannot reproduce from localhost.

    Hopefully this helps to augment your question.  I unfortunately do not have a solution to offer (yet?).
  • seth_coussensseth_coussens Product Owner Ninja IT Monkey ✭✭✭✭
    edited January 29
    Have you set the Remote Management platform configuration file to accept traffic from the hostname you've specified? 

    You will need to make sure your hosts setting includes all the hostnames you will access the server from:

    {
        "defaultApplicationVersion":  "5.1.0-alpha-sdphase2-0352",
        "serviceName":  "ControlCenterService",
        "httpPorts":  "8061",
        "productKey":  "2f06f0e8-****-c925-900e-********",
        "installPath":  "C:\\CiresonPlatform\\platform",
        "connectionString":  "Data Source=localhost;Initial Catalog=ControlCenter-Cyclops;Integrated Security=True;Connect Timeout=15;Trusted_Connection=True;MultipleActiveResultSets=True;Encrypt=True;TrustServerCertificate=True;",
        "defaultApplicationName":  "Cireson.ControlCenter.Core",
        "enableWorkerProcesses":  true,
        "encryptionKey":  "",
        "virtualRoot":  "/",
        "additionalAppSettings":  null,
        "enableWebHost":  true,
        "sslPorts":  "443",
        "hosts":  [
                      "cc-functional.cireson.com",
                      "localhost"
                  ],
        "sslCertificateName":  "Cireson Wildcard",
        "platformVersion":  ""
    }

    This file is usually located here: C:\CiresonPlatform
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    edited January 29
    Depending on how it was installed, the config file can vary.

    Check instructions here for updating the hostnames and bindings in the config file:
    https://docs.cireson.com/articles/#!remote-management-installation/how-to-setup-ssl-for-remote-management

    If you still get the iframe error despite the hostnames being correct another thing to try would be listening on the same port but a different hostname such as:

    http://*:80/remotemanagement 

    Restart your service

    Then configure your integration test for http://cdtciresontest/remotemanagement
Sign In or Register to comment.