IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

Custom Form with typeprojection dont work

Jan_SchulzJan_Schulz Customer IT Monkey ✭
Hi,

i want to use a custom CI Class with a custom form to edit CI objects with special relationships. I have done everything as in the Cireson tutorial from the blog, but my user does not get the custom form displayed. Did someone make this work?

Answers

  • Shane_WhiteShane_White Cireson Support Advanced IT Monkey ✭✭✭
    [email protected]_Schulz

    The Custom CI Class, which configuration Item does it apply to? Is it a Windows Computer for Example?

    What have you got in your <class>.js form at the moment?
    Needs to be something like the below added to the correct form:

    { DataType: "String", PropertyDisplayName: "NetbiosDomainName", PropertyName: "NetbiosDomainName", Required: false, MinLength: 0, MaxLength: 200 }

    Where Property Display Name is the Name that appears on the form and PropertyName is the internal name in the class.

    Thanks,
    Shane.
  • Jan_SchulzJan_Schulz Customer IT Monkey ✭
    @Shane_White i attached the js file. Should i open a Ticket or better solve this here?
  • Shane_WhiteShane_White Cireson Support Advanced IT Monkey ✭✭✭
    @Jan_Schulz

    We can solve this on here, can you confirm your name of the Javascript file is the name of the class?

    Did you then put this file inside of the following folder:
    C:\inetpub\CiresonPortal\ConfigItem?

    Thanks,
    Shane.
  • Shane_WhiteShane_White Cireson Support Advanced IT Monkey ✭✭✭
    You can edit the form by browsing to /DynamicData/Edit/GUID

    The GUID is the Base Entity ID which you can get by going into SQL and looking in the Table, if you select top 1000 rows from your custom table in the db you should see it in here

    Shane.
  • Jan_SchulzJan_Schulz Customer IT Monkey ✭
    edited April 17
    Yeah the file is in the right folder, the filename is equal to the classname and the "Default" formview in the js file is shown when my user opens the item. But the other formview (ZugangsrolleBearbeiter) with the relationship from the typeprojection is not shown.
    regards,
    Jan

  • Shane_WhiteShane_White Cireson Support Advanced IT Monkey ✭✭✭
    For custom type projections you need to go into Admin Settings and Group settings and define your custom type projection in here


    Thanks,
    Shane.
  • Jan_SchulzJan_Schulz Customer IT Monkey ✭
    Hi Shane, sorry i dont mentioned it. I did the configuration in the Group Settings.


    regards,
    Jan
  • Shane_WhiteShane_White Cireson Support Advanced IT Monkey ✭✭✭
    Hi Jan,

    Can you go to Admin Settings > Dynamic Data > The Purge Platform Cache Data?

    See if this works? If not, what are you seeing when you try load the form?

    Thanks,
    Shane.
  • Jan_SchulzJan_Schulz Customer IT Monkey ✭
    @Shane_White ;
    Hi Shane,
    is see the following Default View from the js file


  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭
    @Jan_Schulz - Have you tried recycling the app pool?  You might also try a different browser or flushing the browser cache.  
  • Jan_SchulzJan_Schulz Customer IT Monkey ✭
    @Justin_Workman ;
    Yes i tried using another browser and cleared the browsercache. Furthermore i restarted the whole iis, but Nothing changed. Is there anything else i could do wrong?
  • Jan_SchulzJan_Schulz Customer IT Monkey ✭
    @Shane_White Is there something new what i can check?
    regards,
    Jan
  • Jan_SchulzJan_Schulz Customer IT Monkey ✭
    @Shane_White ;
    Hi Shane, is it better to create an Incident to track the ticket?
    regards,
    Jan
  • Shane_WhiteShane_White Cireson Support Advanced IT Monkey ✭✭✭
    Hey @Jan_Schulz

    Could you please create a ticket so we can track this incident?

    Thanks,
    Shane.
  • Shane_WhiteShane_White Cireson Support Advanced IT Monkey ✭✭✭
    Thanks for logging the ticket.

    For everyone else on the Community we have discovered this is a bug when using Windows Authentication and this is the ref for the Problem:

    https://support.cireson.com/Problem/Edit/PR83782/

    Thanks,
    Shane
Sign In or Register to comment.