IT Monkey:   


Formal Cireson Support (phone, email, and web) is not included with the free Self-Service Portal – Community app. For trouble shooting assistance, take advantage of the Cireson Community to find answers to your questions. However, if you’d like to purchase a Support Package to access more formal Cireson Support (phone, email, and web), please contact us today to learn more on the pricing options.

Why does Search spin and spin and not return results

I have both LIVE and DEV environments now running the Self-Service Community Portal v9.0.13.2019.

Search works fine in DEV and  I can find knowledge articles and request offerings fine (and fast)!

However in our LIVE environment both this version and our previous versions, v8.12.6.2016 (SSP) and 8.0.5.2016 (Analyst Portal) Search simply spins and spins (the three dots) and doesn't return results.  It isn't really a hang because one can select other options on the page and move on to something else.  I can search for incidents using search criteria, that works O.K.  However KnowledgeBase and Search Catalogue Searches don't work.  I upgraded to v9.0.13.2019 in the hope that the issue would be resolved but no joy.  I've also compared the Admin Settings - Setting Items and I can't see anything obvious as there is very little difference between the environments and nothing that screams Search.  Any ideas folks?  Thanks, Ben.

Best Answer

Answers

  • Adam_DzyackyAdam_Dzyacky Customer Contributor Monkey ✭✭✭✭✭

    Is the ServiceManagement DB on a SQL server with full text search enabled?

  • Ben_McGarryBen_McGarry Customer IT Monkey ✭

    Thanks for replying Adam. Much appreciated.

    Question: Is Full Text Search Enabled? Answer: Yes

    I ran the following query to be certain:

    SELECT FULLTEXTSERVICEPROPERTY('IsFullTextInstalled')

    It returned a value of 1.

    Search did work at one point but broke in the previous version of teh Cireson Portal. It took a while before we realised so we can't pinpoint when, where or why?

  • Ben_McGarryBen_McGarry Customer IT Monkey ✭

    Hi @Sha

  • Shane_WhiteShane_White Cireson Support Ninja IT Monkey ✭✭✭✭

    Hi @Ben_McGarry ,

    I don't think the rest of your message has sent fully!

    Thanks,

    Shane

  • Ben_McGarryBen_McGarry Customer IT Monkey ✭
    edited November 13

    Hi Shane,  You hit the nail on the head.  The KnowledgeCatalog and RequestCatalog were missing.  I went to our DEV environment and used the 'Script Catalog As - Create To' options to grab the commands to recreate the catalogs on the Live system and then re-populated each catalog.  It took some time (about 3 hours) for the searches to begin to work.  The KnowledgeCatalog is still giving trouble (it isn't saving my Tables/Views criteria) but you have pointed me in the right direction and now two of the three catalogs are working.  Many thanks, Ben

Sign In or Register to comment.