Home Configuration Manager Ticker

Permission for Operator accounts to view and post Announcement

I'm using the Cireson Ticker App admin and it's works fine with my production SCCM Build 1602. So i want to authorize operators accounts of my team to post annoucement on collection by using the SCCM Console. The annoucement button is only visible for domain admin account, where can i change this permission for cireson ticker app admin ? 

Thx for your help 

Augustin Moreau 


  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Hi Augustin,

    Thanks for the question/suggestion. And great to hear that the app is working for you. I had tested it on Configuration Manager current branch builds (released builds as well as Technical Preview builds) and have had great luck with it.

    With that said, are you sure that the issue is only on the account type? I just tested with my remote user (Wally) who I just made a Server Operator. I am able to see the Announcement button, and create an announcement successfully. Any chance it is an issue with permissions on the security role?

    Let me know and I can test further if you want to provide more detailed information on your scenario.

  • AMoreauAMoreau Member IT Monkey ✭
    Hi Wally, 
    Operators accounts are in a custom security role. In the permissions view for the items collection i don't see any settings for annoucement. What is the required permission for my custom role ? 

    Thanks for your help 



  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Hi Augustin,

    Sorry about that, when you said Operators, I was thinking of the AD group and not a Configuration Manager Security Role :-( Not sure why I thought that way.

    Anyway, in order to use the Ticker app, the admin user must have these two permissions added:
    * Collection - Deploy Client Settings (which you do have enabled above)
    * Inventory Report - Modify

    So you need to ensure that your custom security role has both of those enabled as Yes. I did show this in the webinar that I did on the Ticker app. I actually took the Read Only Analyst role, added those two permissions, and all was functioning as expected.

    Hope that helps,

  • F_ChristiansenF_Christiansen Cireson Dev Advanced IT Monkey ✭✭✭
    Hi Augustin,

    Another thread had a similar question, so to setup a minimum Security Role, please setup the following permissions:
    • Create a custom Security Role and strip it for all permissions.
    • Add "Client Agent Settings": Read
    • Add "Collection": Read, Deploy Client Settings. (Note, you will need Read Resource to display collection members, but the Ticker App doesn't require that)
    • Add "Inventory Reports": Read, Modify
    • Add "Site": Read
    • Add "Status Messages": Read
    The Site read permission is not actually required and the requirement for that permission will be removed in the next version of the Ticker App, but for now you must specify it in order to start the app.

    Hope that answers the question.

    Best regards
    Flemming Appelon Christiansen
  • AMoreauAMoreau Member IT Monkey ✭
    Thanks for your answers, my custom security role can now show the annoucement button. 

    It works fine 

    Best Regards 

  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Fantastic. As Flemming said (he's the dev that wrote it), we'll get the KB and documentation updated with the full set of requirements. We had only gone from what most other roles already had established, not a completely new role. Thanks Augustin.
This discussion has been closed.