Home Analyst Portal

No Serviceoffering's with the new Catalog Item group

Andreas_VoigtAndreas_Voigt Customer IT Monkey ✭
edited July 8 in Analyst Portal

Hi there,

i am currently trying to build a , lets say, ENDUSER-Portal and a ANALYST-Portal.

I got the very good idea here, that working with catalog item groups would solve it for me.

But when trying to build it i encounter strange problems.

Let me explain.


After creating the "new" Enduser-catalog-item-group - and adding the Service-offerings i want the enduser to see -I go to Admin / Sec / User-Roles and select only the "new" Enduser-calatlog-item-group as visible to the User-Role "Enduser".


After doing so and do a Cachebuilder + iisreset my enduser (--> AD-group = DomainUser) just have a blank portal.-


So i tried and marked all catalog-item-groups again

Did a Cachebuilder+iisreset again, but still blank.



ONLY when selecting "All catalog items can be accessed" and after a Cachebuilder+iisreset the portal is working again


Any information would be very appriciated. Even KB's or some background-information about Catalog-item-groups and queues etc. would be very much apprecited. I inherited the system and maybe this is just a design flaw i just encountered.


Regards


Andreas

Answers

  • Andreas_VoigtAndreas_Voigt Customer IT Monkey ✭

    By Coincident the solutioin was already posted in another thread here :




    Could you try running the following command against your Service Management DB and then restarting the Cache Builder please?


    TRUNCATE TABLE LastModified

  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭

    @Andreas_Voigt - So did truncating lastmodified and restarting cachebuilder fix your issue?

  • Andreas_VoigtAndreas_Voigt Customer IT Monkey ✭

    @Justin_Workman

    Hi Justin,


    yes and no ...

    At first it did work, I could see the SO´s that are meant for the Analyst´s only - while using a Analyst account.


    But then i created 3 more catalog item groups and according to this 3 new user roles ( i also need to split the offerings by language )

    and by now none of the 3 catalog item groups are working. Maybe it needs some time in the background to sort things ? I already did the truncate,cachebuilder,iisreset again.

    My testuser ( one for every new user role ) only gets a blank screen.

    I checked in the CacheBuilder, they are scoped correctly , and when checking with the "cireson portal tool under the SQL tab" they are "scoped on config items" , but somehow there is "nothing" shown to this particular scope (?)





  • Andreas_VoigtAndreas_Voigt Customer IT Monkey ✭

    Hi @Justin_Workman


    just wanted to give a follow up.


    My issue is solved now.

    I had a big mess with the SO's languages.

    They were either set wrong, or not set at all.

    Quite interessting to understand that e.g. French is NOT the same as French/France


    So whenever a user picked a language in the portal ( settings ...)

    Then it scoped for SO's that where in his catalog-group, but not his language.

    So everything was blank ...


    But as I said, everything is finally working as supposed.


    BR

    Andreas

Sign In or Register to comment.