Home Self-Service Portal - Community

After updating to Cireson portal to 11.6.3 we get this error with the Cache Builder.

MichaelGustavssonMichaelGustavsson Member IT Monkey ✭

We get this error when running the cireson cachebuilder after updating the free community self-service portal.

System.Data.SqlClient.SqlException (0x80131904): Could not find stored procedure 'spList_ObjectsToUpdate'.

Error Number:2812,State:1,Class:16

2022-09-26 15:57:33,954, ERROR [ 7]: Unable to sync WORK ITEMS, the operation failed permanently. Please review the log for errors, correct them, then restart the cachebuilder service.

Unable to find the spList_ObjectsToUpdate in database, even after installing a new database.

See attached file for log.

Best regards

Michael Gustavsson


  • MichaelGustavssonMichaelGustavsson Member IT Monkey ✭
    edited September 2022

  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭

    @MichaelGustavsson - I wonder if something got missed on the update? Did you try installing the portal again?

  • MichaelGustavssonMichaelGustavsson Member IT Monkey ✭

    @Justin_Workman Yes, we tried to reinstall the portal. We reinstalled the portal with a new database and still we got the same error.

    Best regards

    Michael Gustavsson

  • Ozge_OzkayaOzge_Ozkaya Member Adept IT Monkey ✭✭

    Dear All, we have similar errors in CacheBuilder logs after upgrading to 11.6.3 with SCSM 2019 CU4. For some reason the work items are not fully in sync in the portal. For example, when I submit an SR, the status keep showing New even though it is In Progress in SCSM and in detailed view in the Portal. I tried reinstalling the portal several times but the issue persists. I did not enable Analytics during installation. Only after manually restarting the CacheBuilder service, then the WIs are correctly showing on the portal. Any suggestions please?

  • Michael_SeidlMichael_Seidl Partner Adept IT Monkey ✭✭

    Is there an update on this, as we get the same error?

  • Simon_ZeinhoferSimon_Zeinhofer Customer Advanced IT Monkey ✭✭✭
    edited January 26

    Do you guys only get this one in the free community version?

    Because in our Service Management Portal (not the community version) we noticed performance downgrades since we updated to 11.6.3 - Longer saving times, longer times to open work and/or config items, somertimes it is just when we navigate from one page to the other(dashboards or just the home page). Happens randomly during the day, so I am wondering if you guys experience that as well.

  • Michael_SeidlMichael_Seidl Partner Adept IT Monkey ✭✭

    Yes, it is only affecting the community edition.

    At Customers with a License and the same Version, no issues.

  • Patrick_HammerPatrick_Hammer Member IT Monkey ✭

    Any news here?

    Seems that this stored procedure is not needed for the paid version - did not find it there.

  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭

    That SP only gets checked if the Archiver is turned on. In Admin Settings/Setting Items, you can set EnableCiresonAnalyticsArchive to false and those errors should stop.

  • Patrick_HammerPatrick_Hammer Member IT Monkey ✭

    The Archiver is set to false in our case.

  • Patrick_HammerPatrick_Hammer Member IT Monkey ✭

    So now it seems to be working.

    1. Installed newest version
    2. EnableCiresonAnalyticsArchive = true
    3. Created a procedure [spList_ObjectsToUpdate]

    not sure what helped, but it works at least now.

    In case you want to create the procedure:

    CREATE PROCEDURE [dbo].[spList_ObjectsToUpdate]


    Select * from sys.tables

    where name = 'dfghjskgl'


    Originally the Sp should have a parameter called ObjectList

Sign In or Register to comment.