Home Outlook Console

License Key Expired - but not on every computer

Peter_ForsterPeter_Forster Partner IT Monkey ✭


since today we receive on our Remotedesktop-Server the warning, that the License Key has expired:

On other computers (not Remotedesktop everything is fine). The license will expire End of January 2017.

Installed Versions:

Cireson Console App Licensing: 7.7.2012.96

Outlook Console MP:

Any idea how to fix this?


  • Adam_DzyackyAdam_Dzyacky Product Owner Contributor Monkey ✭✭✭✭✭
    What's worth trying on those machines experiencing this error is closing the SCSM console, deleting the local client cache, and then re-opening the console.

    Local client cache is (I believe...):
    C:\Users\USERNAMEHERE\AppData\Local\Microsoft\System Center Service Manager 2010

    You can optionally just rename the "system center service manager 2010" foder if you're concerned for any reason. Otherwise, the folder is reconstructed on console launch.

    I've occasionally seen the local client cache cease to update for whatever reason preventing things like updated views or Invalid License Key for Cireson appear.
  • Adam_DzyackyAdam_Dzyacky Product Owner Contributor Monkey ✭✭✭✭✭
    edited September 2017
    To Peter_Forster and onlookers - I wanted to follow up on this thread because I ended up encountering the exact same error where everything is licensed, a few computers have issues, and even after the aforementioned fix of mine it still doesn't work! Here's how I managed to solve this and I can no less reproduce on demand.

    First, here are my troubleshooting/observations that kept leading to dead ends:
    • Deleting the aforementioned folder and watching it recreate - As I navigated to Cireson app views/functions within the console, new folders were created/MPs pulled down into the folder but always had a licensing error. I was led to ProcMon thinking I could watch some failure occur but alas everything seemed fine compared to a working machine.
    • In house solutions, overrides, etc. work fine - Before singling this out to a Cireson specific issue, I ensured that in house form customizations, overrides, etc. came down to the client successfully. Sure enough these work entirely fine.
    • Moving between "automatically renew licenses" and "air gapped" ones - Perceiving this to be an issue unique to the machine and not user, I tried flipping settings back n forth from the client. License renewal dates would get retrieved, but the license remained invalid. Committing the change from the client and opening the setting back up was as though I never made the change in the first place.
    • Trying across environments - To really solidfy this was a machine issue, I tried this against PROD and DEV environments, regardless of the environment or validity of the key. This was still an issue.

    All of this said, it feels entirely a Cireson licensing issue. That's when it struck me "I wonder if this affects their free apps?" Opening the Advanced Send Email settings, lo and behold...

    This now entirely seals the solution for me as this error points to a Windows OS related setting. Checking the machines in question I opened up the FIPS setting to discover it was marked as Enabled. I flipped this to Disabled, closed the SCSM console, re-opened and voilà! Cireson functionality restored!

    While it may not be ideal for everyone, the FIPS setting must be marked as "Disabled" or "Not Defined" to restore machines experiencing this issue to working order.

    Does this merit a feature request @james_kleinschnitz and/or @seth_coussens?
Sign In or Register to comment.