Home Analyst Portal

CR Service offering not showing after ICON change

Simon_LovittSimon_Lovitt Customer IT Monkey ✭

I doubt if it has anything to do with the icon change, but a colleague was updating icons in the portal, republished the RO as a regular RO, realized the mistake and republished as an advanced RO, and then published the SO. ( The RO is the CR workaround ). Now the offering is missing form the portal, (but it is on the MS portal) and all previous CRs created have lost the ability to edit. I had the inability to edit issue before, and this turned out to be a permissions issue, but not this time. Gone through all the usual steps of resetting IIS/browser/Cache builder to no avail.  One other oddity was that the first symptom was the loss of ability to edit from my Admin account, but may user account was fine, CR was available on the portal.  Then in the process of trying to get the admin account back working, first the offering disappeared from the portal, then my regular account lost the ability to edit.

The cachebuilder log has this error, but this was after the initial problems:

2017-06-22 16:56:26,106, ERROR [   4]:  Error connecting to management server: The Data Access service is either not running or not yet initialized. Check the event log for more information.

So I am somewhat stumped her, maybe this is a SQL issue?

Best Answer


  • Simon_LovittSimon_Lovitt Customer IT Monkey ✭
    Just realized I posted this in the wrong place, but cant see how to delete and/or move to the right forum?
  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Hi Simon

    I have moved this one for you.

    Are you still seeing new errors logged about the data access service not running when you restart the cachebuilder?

    If not then that is good, assuming the RO is all published correctly, attached to SO and if scoped assigned to the appropriate catalog groups - then id recommend trying a service catalog resync by truncating SO,RO and last modifed table as described in the below KB:

    Let me know if that helps or not.
  • Simon_LovittSimon_Lovitt Customer IT Monkey ✭
    Thanks Joe,

    No errors in the cachebuilder log, debug is turned on and logs sent to support.

    Tried truncating, but no go I am afraid. I know everything is published correctly as it was working and nothing changed, apart form what i described in the original post, which again I am not sure why its happening. There are 2 groups assigned the same in SCSM, one group have no problem with creating the CR, the group I am in does. I tried adding myself to that group but that didn't help, but I'll try again after the truncate.
  • Peter_SettlePeter_Settle Customer Advanced IT Monkey ✭✭✭
    The truncate should definitely sort out your issue.
  • Simon_LovittSimon_Lovitt Customer IT Monkey ✭
    Adding myself to the other group worked, but I do not want to be in that group. Is there something I can run that will show me the permission differences Cireson sees? I have added my group to all the same permissions in the SM/Administration/Security/User roles. Underlying SM permissions are fine, as I can create and edit CRs directly in the SM console. Anything specific i need to add to the Admin Setting/Setting items in the portal, the group that works is assigned to a few keys in there?
  • Peter_SettlePeter_Settle Customer Advanced IT Monkey ✭✭✭
  • Peter_SettlePeter_Settle Customer Advanced IT Monkey ✭✭✭

    Have you also seen the support article that is mentioned in the above post.


  • Simon_LovittSimon_Lovitt Customer IT Monkey ✭
    Thanks Peter, there are some good analysis tools there. I'll run through them and see what I come up with.
  • Simon_LovittSimon_Lovitt Customer IT Monkey ✭
    ok, I have been through all the user roles and permissions, using the SQL queries and the Ps script and nada, everything looks as it should be. 
  • Simon_LovittSimon_Lovitt Customer IT Monkey ✭
    Answer ✓
Sign In or Register to comment.