Error Installing the CMP v2.0

I get this error when installing the 2.0 community version. 

6/23/2017 5:41:22 PM Error processing powershell: The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Cannot find drive. A drive with the name 'IIS' does not exist. 
   at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
   at System.Management.Automation.PipelineOps.InvokePipeline(Object input, Boolean ignoreInput, CommandParameterInternal[][] pipeElements, CommandBaseAst[] pipeElementAsts, CommandRedirection[][] commandRedirections, FunctionContext funcContext)
   at System.Management.Automation.Interpreter.ActionCallInstruction`6.Run(InterpretedFrame frame)
   at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)
   at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)


Comments

  • Joe_BurrowsJoe_Burrows Cireson Devops Super IT Monkey ✭✭✭✭✭
    Hi Randy

    Can you try manually run the powershell script InstallCMPPreReq.ps1 first then re-run the installer to see if that helps?

    Regards
    Joe
  • Randy_ReamesRandy_Reames Member IT Monkey ✭
    I get the same error after running the script.

    Thanks,
    Randy
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    Did you unblock the installation files?
  • Randy_ReamesRandy_Reames Member IT Monkey ✭
    It looks like all the pre-reqs are installed ok. I also ran them manually and they all completed.
  • merlenette_jonesmerlenette_jones Member Advanced IT Monkey ✭✭✭
    Did you unblock the zip file that the install came in?
  • Randy_ReamesRandy_Reames Member IT Monkey ✭
    it is not blocked
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Hi Randy,

    Did you get this resolved? Sorry for missing it when I was viewing other posts. When I've seen that error from others, it has indeed been what has been suggested earlier in this thread - that the zip files are blocked. But not just the main one that you download from Cireson.com, however the other zips included inside the main zip. I know one person unblocked the main zip, got the error. Then when we had him unblock the included zips, the install completed successfully.

    And his error was the same as yours - the drive "IIS does not exist" error.

    Check that out and we'll see if we can get you going if you are not already,

    Wally
  • Randy_ReamesRandy_Reames Member IT Monkey ✭
    I got past the first error, I unblocked all the directories and recopied them. I am now getting the following error:

    7/10/2017 11:25:10 AM Starting to deploy the website...

    7/10/2017 11:25:10 AM Error processing powershell: The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: \Cireson was unexpected at this time. 
       at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
       at System.Management.Automation.PipelineOps.InvokePipeline(Object input, Boolean ignoreInput, CommandParameterInternal[][] pipeElements, CommandBaseAst[] pipeElementAsts, CommandRedirection[][] commandRedirections, FunctionContext funcContext)
       at System.Management.Automation.Interpreter.ActionCallInstruction`6.Run(InterpretedFrame frame)
       at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)

    Thanks,
    Randy
  • wally_meadwally_mead Member Advanced IT Monkey ✭✭✭
    Well good that you got past one error, but bad that you are encountering another one. Can you either post, or send me, the full log so that I can have the developer of the Installer to look at it? They often need to see the full log file to troubleshoot. If you want to email me, it is [email protected]
Sign In or Register to comment.