User account is removed with any known reason

Wolfgang_SchmidtWolfgang_Schmidt Customer IT Monkey ✭
Hi guys,

I am experimenting an issue and I don't understand the reason. I have defined an AD Connector that syncs users. One user was created correctly and I see his account in Cireson Portal but after some hours the account does not exists into SCSM database database.

Cache builder show: cn=XXX.... is a member of cn=XXX, but does not exist in the database.


Answers

  • Roland_KindRoland_Kind Partner Advanced IT Monkey ✭✭✭

    Hi,

    maybe the user been deleted in AD or moved from the ou were it was created

    have you checked the deleted items container under administration in the scsm console ?

  • Wolfgang_SchmidtWolfgang_Schmidt Customer IT Monkey ✭
    Hi,

    My surprise is "Deleted Items" view is returning an exception. I checked some forums and blogs and looks like an old error coming from version SCSM 2012 R2. I checked all deleted items from powershell and I did not find this user reference but maybe I need to solve this view problem after to follow because maybe the info is in this view but not available for the error source.

    ##############
    Date: 14.11.2017 12:04:16
    Application: Service Manager Console
    Application Version: 7.5.7487.0
    Severity: Error
    Message: An error occurred while loading the items.

    Microsoft.EnterpriseManagement.UI.ViewFramework.AdvancedListSupportException: The Full adapter threw an exception. See the FullUpdate property to see the exception.
       at Microsoft.EnterpriseManagement.UI.ViewFramework.AdvancedListSupportAdapter.DoAction(DataQueryBase query, IList`1 dataSources, IDictionary`2 parameters, IList`1 inputs, String outputCollectionName)
       at Microsoft.EnterpriseManagement.UI.DataModel.QueryQueue.StartExecuteQuery(Object sender, ConsoleJobEventArgs e)
       at Microsoft.EnterpriseManagement.ServiceManager.UI.Console.ConsoleJobExceptionHandler.ExecuteJob(IComponent component, EventHandler`1 job, Object sender, ConsoleJobEventArgs args)##########

  • Roland_KindRoland_Kind Partner Advanced IT Monkey ✭✭✭

    Hi,

    just to be sure: the user in AD still exists, but not in SCSM (nor as deleted item or active item) the user was synced with cireson db and now disappeared.

    maybe you can check the event log on the (primary workflow) server - especially the Application and Services log - Operations Manager log - this log contains info about the native scsm connectors (LFX --> AD/SCCM) and other useful info regarding the SCSM DB.

    It is no problem to rebuild the Cireson (User) DB (https://support.cireson.com/KnowledgeBase/View/1142#/) refer to the last point - but I assume this does not solve your problem completly...

    Is this the only user - or are there others, too with the same problem ?

    regards


  • Wolfgang_SchmidtWolfgang_Schmidt Customer IT Monkey ✭
    That is. I add the user on Friday and Saturday I can set this user as affected user into Cireson portal, that means the user was created correctly by AD Connector. But today the account is missed and I did not find it in deleted items using PowerShell. I will follow your suggestion and I give an update.


  • Wolfgang_SchmidtWolfgang_Schmidt Customer IT Monkey ✭
    Error importing solutions. Error message:Exception type:DatacenterException
    Exception message:Error dropping temp staging. DropTempTables: Cannot drop the table 'LFXSTG.stg4_43_AD_User', because it does not exist or you do not have permission..
    StackTrace:   at Microsoft.EnterpriseManagement.ServiceManager.Connector.Datacenter.DatacenterClass.DropTempTables(Int32 dataSourceId)
       at Microsoft.EnterpriseManagement.ServiceManager.Connector.Datacenter.DatacenterClass.DropTempTablesForCollection(String dataCollectionName)
       at Microsoft.EnterpriseManagement.ServiceManager.Connector.SessionManager.DataProvider.registerDataCollection(XPathNavigator nav, Int32 groupId, Int32 connectorId, String clientName)
       at Microsoft.EnterpriseManagement.ServiceManager.Connector.SessionManager.DataProvider.RegisterDataProvider(XPathNavigator node)
       at Microsoft.EnterpriseManagement.ServiceManager.Connector.Datacenter.DatacenterClass.Configure(XPathNavigator xpath)
       at Microsoft.EnterpriseManagement.SystemCenter.LinkingFramework.MomIntegration.LfxObjects.SyncConnectors()

  • Roland_KindRoland_Kind Partner Advanced IT Monkey ✭✭✭

    you can check the scsm db, if the table/view exists with SQL Management Studio - it the table exists, maybe the service account passwords have been changed ? - they can be adjusted in the console administration -> security  -> run as accounts

Sign In or Register to comment.