Home Analyst Portal - Community

Searches - My Searches (Saved Searches Disappearing)

Good Afternoon,

I've had a few users report that they've created/saved searches in the "My Searches" category under search, only to find upon logging back in after a day or so that they're wiped out. Is this a limitation of the community edition of the portal?

Answers

  • Patrick_ChambersPatrick_Chambers Cireson Consultant Adept IT Monkey ✭✭
    @Adam_Hill

    What version of the portal are you experiencing these issues with?
  • Adam_HillAdam_Hill Customer IT Monkey ✭
    Hi @Patrick_Chambers sorry for the delay

    "Current Portal Version: 8.12.6.2016"
    "Management Pack Version: 7.7.2016.185"
  • prkprk Member IT Monkey ✭
    edited March 27

    Hi @Patrick_Chambers

    I am experiencing the same issue.

    I have found out that what causing it is Recycling on ISS. Confirmed by running manual recycle

    We have changed some settings (marked red) in the ISS / Application Pools / CiresonPortal / Advanced Settings


    That is something that was set by our consultant when first version of CiresonPortal was installed. I believe that was version 7.

    What can we do to stop saved searches to disappear? Can we just not run Recycle ever?

  • Adam_HillAdam_Hill Customer IT Monkey ✭
    edited March 27

    @prk

    Yes! I'm thrilled you've determined this was the problem, because I had been stumped for the longest time. Very curious if leaving this off is viable or what the fix may be.

  • prkprk Member IT Monkey ✭
    edited March 27

    Forgot to add versions.

    Current Portal Version: 9.4.13.2016

    Management Pack Version: 7.7.2016.220

    Platform Cache Version: 3009.4.13

    Platform Version: 5.3.3

  • prkprk Member IT Monkey ✭

    @Adam_Hill

    I hope someone from Cireson can answer that.

  • Patrick_ChambersPatrick_Chambers Cireson Consultant Adept IT Monkey ✭✭

    @prk @Adam_Hill

    I am having someone on our side verify if this is expected behavior for the community edition.

  • Peter_MuttenthalerPeter_Muttenthaler Partner Adept IT Monkey ✭✭

    I asked Cireson support, they do not limit the saved search function in the community version

    So its probably a bug, but one I haven't in the licensed version...

  • Shane_WhiteShane_White Cireson Support Super IT Monkey ✭✭✭✭✭

    To @Peter_Muttenthaler's point, yes we do not believe the saved search feature is being limited by the community version.

    It also seems strange that it takes a day before it deletes. Part of me feels if it was limited, it would delete straight away or not even save!

    I am going to test this in my lab and confirm that fact though.

    Also, Adam, would you be able to update your portal version? You are quite a few behind so this could be contributing to the issue as well.

    Thanks,

    Shane

  • Shane_WhiteShane_White Cireson Support Super IT Monkey ✭✭✭✭✭

    Okay interesting.. so in the community edition of the portal.

    1. Create saved search
    2. Save it, refresh, changes page come back, still there
    3. Restart CacheBuilder and IIS
    4. Saved search no longer exists

    When doing the same steps in the licensed version of the portal this is not an issue.

    Leave this with me and I will speak to the devs!

    Thanks,

    Shane

  • Peter_MuttenthalerPeter_Muttenthaler Partner Adept IT Monkey ✭✭

    @Shane_White

    Thank you for your reply, I've asked my customer to test and give me feedback

    I will reply asap ;)

  • Shane_WhiteShane_White Cireson Support Super IT Monkey ✭✭✭✭✭

    Hi @Peter_Muttenthaler, @Adam_Hill, @prk

    I have relpicated this issue and raise a bug for it PR100466

    I have created an IR for Peter so he can track when this is released.

    Hope this helps guys :-)

    Thanks,

    Shane

  • Peter_MuttenthalerPeter_Muttenthaler Partner Adept IT Monkey ✭✭

    @Shane_White

    Thank you again for your fast and great support ;) !!!

Sign In or Register to comment.