Home Orchestrator

SR fails - runbook issues

Mina_SaidiMina_Saidi Customer IT Monkey ✭

I have noticed that our SR's are failing when its trying to run a RB which is access approval.

the manager is set, and active and this has worked before many times but now it isnt working at all.

i have checked the orchestrator services and everything seems to be up.

i have tried different RO that have manager approvals and used different managers but they all fail.

nothing has changed so i don't know why this suddenly stopped working. any ideas on what to look for?

any help will be appreciated. Thanks


  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Hi Mina,

    Your runbook Log and History should tell you why its failing. Unless its failing to even start the runbook. Looking at the image, the runbook appears to be checked out which would cause this.

  • Mina_SaidiMina_Saidi Customer IT Monkey ✭

    it looks like it doesn't even start the runbook. how do I check it back in? I cant see any logs it, it doesn't come up as failed in the web console.

  • Geoff_RossGeoff_Ross Cireson Consultant Super IT Monkey ✭✭✭✭✭
    Check in the Runbook designer

  • Mina_SaidiMina_Saidi Customer IT Monkey ✭
    i undid the check out, did a test and still failed. under logs there isnt anything. it fails right at the first step.
  • Mina_SaidiMina_Saidi Customer IT Monkey ✭
    this is fixed now.

    in the console - library - runbooks
    the status was set to 'missing' for some and 'active' for others.

    i first tried the below query against the orchestrator database
    TRUNCATE TABLE [Microsoft.SystemCenter.Orchestrator.Internal].AuthorizationCache

    but it didnt work. so then i resync the orchestrator conenctor and it worked.

    glad its working.

    Thanks for helping out. much appreciated.

Sign In or Register to comment.