IT Monkey:   Click Here to Help Me Build the Agenda for Upcoming Cireson Webinars!

How can I troubleshoot custom CI not showing up in Dynamic Data OData feed?

Greg_LawsGreg_Laws Customer IT Monkey ✭
I've created a custom CI that has been working well for a few weeks in the SCSM Console directly.  Today I tried adding the CI class to the Dynamic Data table filters list, but no matter what I do it never shows up in the OData API.  I've confirmed the table name from the database, I've reset the cache, restarted Cache Builder numerous times and it will not show up.  I've also tried several different browsers to make sure that wasn't the issue.  What else can I look at to troubleshoot this issue?

Our Portal version is 9.1.0.2016.

Thanks!

Best Answer

Answers

  • Brett_MoffettBrett_Moffett Cireson PACE Super IT Monkey ✭✭✭✭✭
    Hi @Greg_Laws
    I've seen some tables that do not work with the first few letters on them.
    I had to remove Cached_MT_ from the start of my data table to get this to work.
    Here in the Dynamic Data you can see I just typed CiresonDataCircuit as the table name:


    But when you get in to the OData the name shows in full, like this:


    So as you can see the table name in the database is Cached_MT_CiresonDataCircuit, but in the Dynamic data I had to just enter the CiresonDataCircuit text to get it to appear.

    Hope this also works for you.
  • Greg_LawsGreg_Laws Customer IT Monkey ✭
    @Justin_Workman, that was it.  A restart of the Platform Cache service and some patience has resolved my issue.  New habits to build now that there are two cache services to manage.  Thanks!

    @Brett_Moffett, thanks for your reply.  I had tried this prior to following Justin's advice, and obviously it didn't help because I was restarting the wrong service.  In the end, the collection that is working has the "Cached_MT_" prefix.
Sign In or Register to comment.