Home Service Manager

AD Connector will not work

T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭

Hi all! I have an AD connector that was working fine, but I imported some MPs from an old environment and now it's not functioning. If I tell it to sync, it acts like it will, but never does. I checked the Run As accounts and sure enough, the account that handled it got changed to Local System. I changed that back to what it should be, and went back in the connector and made sure it was there too, and tested the connection successfully, but still no dice when it tries to run. The only thing I haven't tried is blowing away the connector. There's nothing in Event Viewer showing any errors for this either that I can tell. Anywhere else I can check?

Best Answer


  • Brian_WiestBrian_Wiest Customer Super IT Monkey ✭✭✭✭✭

    Check your "Operations Manager" Event Logs and see what it reports when you click the syn now option.

  • Adam_DzyackyAdam_Dzyacky Product Owner Contributor Monkey ✭✭✭✭✭

    Other item worth checking here is running System processes. In the case of the workflow server, I believe it's the Health Service that creates 3 new processes of MonitoringHost.exe. In either case, you should expect to find 3 of these running.

    • One running from your SCSM Service Account
    • One running from your SCSM Workflow Account
    • One running as Network Service

    I'm partial to SysInternals Process Explorer in this case as you can see processes spin up (light up green) or prepare to stop (light up red). If you don't see these, it would lead me to believe there is a permissions issue or something environmental occurring preventing their respective startup. Without them, manually kicking off connectors, scheduled connector times, and workflows - will not run.

  • T_R_Ash_McCan_1T_R_Ash_McCan_1 Member IT Monkey ✭

    Thanks everyone, I followed Mikkel's advice, and I got a successful sync. Odd, but I'll take it, and I'll remember it for future issues. Adam, Process Explorer is amazing. I'm keeping an eye on things on my dev and prod workflow servers with it. Thanks!

Sign In or Register to comment.