How To - Stop Logging BarCode CacheBuilder

Conner_WoodConner_Wood Customer Advanced IT Monkey ✭✭✭
It's easy to forget that the Cireson BarCode CacheBuilder makes its own logs, which can very quickly take up the entire hard drive depending on the size of your environment.

Rather than make a script through Task Scheduler to delete logs older than X amount of days, it'd be much more efficient to turn off logging.  Because let's face it, we don't ever check these logs.  At best, a problem is reported by the users and then we might turn the logs on for troubleshooting purposes.  The point is these logs are not suitable for being constantly made and I've troubleshooted with these logs before regarding the Cireson Barcode only uses Old License Keys Issue which didn't really offer enough information in the first place so we're not missing out.

In order to turn off the cache builder logging for the Cireson BarCode CacheBuilder we must alter logger levels:
  1. Open the folder:  "C:\inetpub\CiresonWebAPI\CacheBuilder\WindowsService"
  2. Now edit the file with Notepad++:  "log4net.Config"
  3. Find the logger with a name of "BuildLogger" and set the level value from ALL to OFF
  4. Find the logger with a name of "UpdateLogger" and set the level value from ALL to OFF
  5. Optionally you could duplicate and comment out the original line, then modify said duplicate



Now save the file, if it says it wants Administrator Level, hit ok and save the file again.

Now go into the folder:  "C:\inetpub\CiresonWebAPI\CacheBuilder\WindowsService\Logs"

Go ahead and delete all the logs you can to free up space, you won't be able to delete the logs that are currently in use, but if you really wanted to, you could stop the CacheBuilder Service, delete the logs and then start the CacheBuilder Service again, which when thinking about it, it's a good check to know it's no longer writing to the log files.

Misc. The full list of Logger levels in increasing priority are as follows:  ALL, DEBUG, INFO, WARN, ERROR, FATAL, OFF
This discussion has been closed.