Home General Discussion

Affected User Relationship property

JansiJansi Member IT Monkey ✭

Hi Team,

I tried something for see the incident class properties with the below command and it is working fine.

$IC=get-scsmclass -name system.workitem.incident$

$IC.getproperties("recursive") | add-member -pass noteproperty class $IC --> This command retrieves almost all of the fields for the incident module with few columns as (Name, Key, Required, AutoIncrement, Type and DisplayName)

Similarly, I tried to get the "affecteduser" using Relationship class. I used the below commands. Unfortunately, it did not work.

$RC=get-scsmrelationshipclass -name system.workitemaffecteduser$

$RC.getproperties("recursive") | add-member -pass noteproperty class $RC --> This is not working

Could anyone please let me know what was wrong in the above command?

Appreciate your help!!!




  • Justin_WorkmanJustin_Workman Cireson Support Super IT Monkey ✭✭✭✭✭

    It looks like you're trying to retrieve the properties of the relationship, not the related object. Are you wanting the properties on the user class?

Sign In or Register to comment.