Home Service Manager

Duplicate Entries inside the LFXSTG.AD_User Table

Simon_ZeinhoferSimon_Zeinhofer Customer Advanced IT Monkey ✭✭✭
edited November 15 in Service Manager

Hello guys,

in our company people are often hired as Leasing employees. When they are then changed to internal they receive a new personal number and username --> so in SCSM a new user object is created. So we have a service request with lots of automation for that, so the new user object gets all the relationships form the old user and afterwards the old user gets deleted. When everything is correct no new user object is created in AD, when the personal number has been changed in SAP. But sometimes this is not done correctly and a new user in AD gets created (and deleted afterwards, after the old iuser has been changed)

Now we have 2 users, who both got changed incorrectly (so a new AD user was created and deleted), where we have 2 entries inside the LFXSTG.AD_User table (We only have one user connector and the datasource id is the same for both entries). Both have the same employee id and username, displayname, but the Distinguished Name is different (new users are always in a newuser OU and are moved afterwards), Business Phone is NULL and so on. And this object does not even exist in SCSM or AD (the new user object, which gets synced automatically after the username change from SAP gets deleted and the existing AD object will be updated) anymore, but in the table it is still present, the timestamp is not updated anymore. Both of these users had the same problem last week, that they don't see ANY request offerings and don't have access to any work items. One of them is an analyst, so he was very limited in his work. Yesterday I deleted this user object, today I reset the connector watermark and restarted the cachebuilder. Now it works. But we had the same situation last week, where it worked one day and the next day it didn't. Then we did a connector watermark reset and it worked for one day and so on.

For the non analyst user it is still not working, although we deleted the user object, let the grooming purge it out, resynced it and so on.

TL,DR: It is strange, that all these issues only occur on users, which have duplicate entries in the LFXSTG.AD_User table. So my question here is:

May I just delete the 2 obselete entries from this table? Or will this lead to some problems in the future? I just checked some users from recent personal number changes, and there is only one entry for those.

Sign In or Register to comment.